Unbounded decompression in armeria-saml enables denial of service
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
LY Corporation's Armeria (armeria-saml) versions prior to 1.43.0 are affected. The HTTP-Redirect binding decoder decompresses SAML messages without limiting the output size before signature validation. An unauthenticated remote attacker can exhaust server memory and cause a denial of service.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
Description from the CNA
A vulnerability has been identified in armeria-saml versions prior to 1.43.0, where the HTTP-Redirect binding decoder decompresses attacker-supplied SAML messages without limiting the output size before signature validation, allowing an unauthenticated remote attacker to exhaust server memory and cause a denial of service.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| LY Corporation | Armeria | — | 1.43.0 | Patch available | CNA |
- Armeria VendorLY Corporation Affected — Fixed in 1.43.0 Patch available CNA
Remediation
Upgrade Armeria to version 1.43.0, which contains the fix.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
- Fix · CNA Armeria (LY Corporation) Fixed in 1.43.0
Timeline
- 2026-11-06 Threatist record created from CVE-2026-121820
- 2026-11-07 Priority changed: MEDIUM → LOW
References
More LY Corporation vulnerabilities
- TI-2026-10143 Hard-coded credentials in LY Corporation Central Dogma CVSS 4.0CRITICAL 9.4
- TI-2026-10142 A vulnerability has been identified in centraldogma-server-mirror-git versions prior to… CVSS 4.0HIGH 8.8
- TI-2026-10145 LDAP injection in LY Corporation Central Dogma CVSS 4.0MEDIUM 6.9
- TI-2026-14054 A code injection vulnerability exists in the LINE Android app prior to version 26.7.2. CVSS 4.0HIGH 8.7
- TI-2026-10146 A vulnerability has been identified in armeria-xds versions prior to 1.41.0, where xDS… CVSS 4.0CRITICAL 9.1
- TI-2026-85778 Excessive memory allocation in Armeria from malformed Thrift messages CVSS 4.0HIGH 8.7
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences