Insufficient warning in JetBrains Toolbox App login dialog
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
JetBrains Toolbox App before 3.9 has an insufficient warning in its login dialog (CWE-357). The dialog does not clearly warn users before they connect to a server, so a user can be led to connect to a malicious server. The CVSS vector indicates a remote attacker needs no privileges but requires user interaction, and the impact is low integrity loss with no confidentiality or availability impact.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
Description from the CNA
In JetBrains Toolbox App before 3.9 insufficient warning in the login dialog allowed connecting to a malicious server
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
Update JetBrains Toolbox App to version 3.9 or later, which is listed as the fixed version.
Written with Claude Haiku 5.5 from the sources below · 2026-11-06
- Fix · CNA Toolbox App (JetBrains) Fixed in 3.9
Timeline
- 2026-11-06 Threatist record created from CVE-2026-123320
- 2026-11-06 Alias added: GHSA-hm7w-w8p9-8rj2
References
More JetBrains vulnerabilities
- TI-2026-45031 Deserialization of untrusted data in JetBrains TeamCity KEVCVSS 3.1CRITICAL 9.8
- TI-2024-18053 In JetBrains TeamCity before 2023.11.4 authentication bypass allowing to perform admin actions was possible KEVCVSS 3.1CRITICAL 9.8
- TI-2023-22884 In JetBrains TeamCity before 2023.05.4 authentication bypass leading to RCE on TeamCity Server was possible KEVCVSS 3.1CRITICAL 9.8
- TI-2024-18054 In JetBrains TeamCity before 2023.11.4 path traversal allowing to perform limited admin actions was possible KEVCVSS 3.1HIGH 7.3
- TI-2024-15905 In JetBrains TeamCity before 2023.11.3 authentication bypass leading to RCE was possible CVSS 3.1CRITICAL 9.8
- TI-2024-24589 Insufficiently protected credentials in JetBrains IntelliJ IDEA CVSS 3.1CRITICAL 9.3
Sources
- CVE-2026-123320 · CVE Program
- CVE-2026-123320 · NVD
- FIRST EPSS
- GHSA-hm7w-w8p9-8rj2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences