Memory exhaustion in imgproxy ICO loader enables denial of service
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-789.
Summary
imgproxy from 3.3.0 before 4.0.16 fails to validate the data_size field in its ICO loader, so it makes an unbounded memory allocation (CWE-789). An unauthenticated remote attacker can supply a crafted 23-byte ICO file declaring a data_size of about 4GB, which exhausts memory and crashes workers.
Written with Claude Haiku 5.5 from the sources below · 2026-11-08
Description from the CNA
imgproxy from 3.3.0 before 4.0.16 contains an unbounded memory allocation vulnerability in the ICO loader that fails to validate the data_size field. Attackers can supply a crafted 23-byte ICO file declaring a ~4GB data_size to trigger memory exhaustion and worker crashes without authentication.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
Update imgproxy to version 4.0.16 or later.
Written with Claude Haiku 5.5 from the sources below · 2026-11-08
- Fix · CNA imgproxy (imgproxy) Fixed in 4.0.16
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
imgproxy 4.0.16
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2026-86756 Heap buffer overflow in imgproxy ICO loader lets attackers crash or run codePriority MEDIUM 55
Timeline
- 2026-11-08 Threatist record created from CVE-2026-123616
- 2026-11-08 Alias added: GHSA-97wv-7mx5-f6w4
References
More imgproxy vulnerabilities
- TI-2026-86756 Heap buffer overflow in imgproxy ICO loader lets attackers crash or run code CVSS 4.0CRITICAL 9.3
- TI-2026-86757 Out-of-bounds write in imgproxy ICO loader crashes worker CVSS 4.0HIGH 8.7
- TI-2025-18097 imgproxy is vulnerable to SSRF against 0.0.0.0 CVSS 3.1MEDIUM 5.3
Sources
- CVE-2026-123616 · CVE Program
- CVE-2026-123616 · NVD
- GHSA-97wv-7mx5-f6w4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences