Priority LOW 37
Cloud foundry instances having CAPI version between 1.140 and 1.152.0 along with loggregator-agent v7+ may override other users syslog drain credentials if they're aware of the client certificate used for that syslog dra…
CVSS 3.1HIGH 8.1· Network · Low privileges · No interaction · EPSS 0.00362 · Published 2023-05-19 · No fix listed CWE-295
Priority LOW 26
In cloud foundry CAPI versions prior to 1.122, a denial-of-service attack in which a developer can push a service broker that (accidentally or maliciously) causes CC instances to timeout and fail is possible.
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.00915 · Published 2022-03-25 · No fix listed CWE-400
Priority LOW 35
Cloud Controller versions prior to 1.118.0 are vulnerable to unauthenticated denial of Service(DoS) vulnerability allowing unauthenticated attackers to cause denial of service by using REST HTTP requests with label_selec…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.01004 · Published 2021-10-27 · No fix listed CWE-400
Priority LOW 30
Cloud Controller API versions prior to 1.106.0 logs service broker credentials if the default value of db logging config field is changed.
CVSS 3.1MEDIUM 6.5· Network · Low privileges · No interaction · EPSS 0.00836 · Published 2021-04-08 · No fix listed CWE-522
Priority LOW 35
CAPI (Cloud Controller) versions prior to 1.101.0 are vulnerable to a denial-of-service attack in which an unauthenticated malicious attacker can send specially-crafted YAML files to certain endpoints, causing the YAML p…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.01145 · Published 2020-12-02 · Fixed in 1.101.0, 15.0.0 CWE-400
Priority LOW 21
Cloud Foundry CAPI (Cloud Controller) versions prior to 1.98.0 allow authenticated users having only the "cloud_controller.read" scope, but no roles in any spaces, to list all droplets in all spaces (whereas they should…
CVSS 3.1MEDIUM 4.3· Network · Low privileges · No interaction · EPSS 0.00575 · Published 2020-09-03 · Fixed in 1.98.0, 13.17.0 CWE-863
Priority MEDIUM 40
Cloud Foundry CAPI (Cloud Controller), versions prior to 1.97.0, when used in a deployment where an app domain is also the system domain (which is true in the default CF Deployment manifest), were vulnerable to developer…
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.00986 · Published 2020-08-21 · Fixed in 1.97.0, 13.12.0 CWE-732
Priority LOW 30
Cloud Foundry Cloud Controller (CAPI), versions prior to 1.91.0, logs properties of background jobs when they are run, which may include sensitive information such as credentials if provided to the job.
CVSS 3.1MEDIUM 6.5· Network · Low privileges · No interaction · EPSS 0.00753 · Published 2020-02-27 · Fixed in 1.91.0 CWE-522
Priority LOW 21
Cloud Foundry Cloud Controller API (CAPI), version 1.88.0, allows space developers to list all global service brokers, including service broker URLs and GUIDs, which should only be accessible to admins.
CVSS 3.1MEDIUM 4.3· Network · Low privileges · No interaction · EPSS 0.00778 · Published 2019-12-19 · No fix listed CWE-200
Priority LOW 36
Cloud Foundry Cloud Controller API Release, versions prior to 1.79.0, contains improper authentication when validating user permissions.
CVSS 3.0HIGH 7.5· Network · Low privileges · No interaction · EPSS 0.01339 · Published 2019-04-17 · Fixed in 1.79.0 CWE-287
Priority LOW 38
Cloud Foundry Cloud Controller, versions prior to 1.78.0, contain an endpoint with improper authorization.
CVSS 3.1HIGH 8.1· Network · Low privileges · No interaction · EPSS 0.0127 · Published 2019-03-13 · Fixed in 1.78.0 CWE-285
Priority LOW 26
Cloud Foundry Cloud Controller, capi-release versions prior to 1.0.0 and cf-release versions prior to v237, contain a business logic flaw.
CVSS 3.0MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.00968 · Published 2018-04-18 · No fix listed CWE-17
Priority LOW 38
Cloud Foundry Cloud Controller, versions prior to 1.52.0, contains information disclosure and path traversal vulnerabilities.
CVSS 3.1HIGH 8.1· Network · Low privileges · No interaction · EPSS 0.01129 · Published 2018-03-27 · No fix listed CWE-22
Priority MEDIUM 40
In Cloud Controller versions prior to 1.46.0, cf-deployment versions prior to 1.3.0, and cf-release versions prior to 283, Cloud Controller accepts refresh tokens for authentication where access tokens are expected.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.00983 · Published 2018-03-19 · No fix listed CWE-613
Priority LOW 31
An issue was discovered in Cloud Foundry Foundation capi-release (all versions prior to 1.45.0), cf-release (all versions prior to v280), and cf-deployment (all versions prior to v1.0.0).
CVSS 3.1MEDIUM 6.5· Network · Low privileges · No interaction · EPSS 0.00945 · Published 2017-11-28 · No fix listed
Priority LOW 36
In Cloud Foundry Foundation CAPI-release versions after v1.6.0 and prior to v1.38.0 and cf-release versions after v244 and prior to v270, there is an incomplete fix for CVE-2017-8035.
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.01415 · Published 2017-08-21 · No fix listed CWE-200
Priority LOW 36
An issue was discovered in the Cloud Controller API in Cloud Foundry Foundation CAPI-release versions after v1.6.0 and prior to v1.35.0 and cf-release versions after v244 and prior to v268.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.01387 · Published 2017-07-25 · No fix listed CWE-200
Priority LOW 36
An issue was discovered in the Cloud Controller API in Cloud Foundry Foundation CAPI-release versions prior to v1.35.0 and cf-release versions prior to v268.
CVSS 3.1HIGH 7.8· Local · No auth · User interaction · EPSS 0.01018 · Published 2017-07-25 · No fix listed CWE-22
Priority LOW 37
An issue was discovered in the Cloud Controller API in Cloud Foundry Foundation CAPI-release version 1.33.0 (only).
CVSS 3.1HIGH 7.8· Local · No auth · User interaction · EPSS 0.01425 · Published 2017-07-24 · No fix listed
Priority LOW 31
The Cloud Controller and Router in Cloud Foundry (CAPI-release capi versions prior to v1.32.0, Routing-release versions prior to v0.159.0, CF-release versions prior to v267) do not validate the issuer on JSON Web Tokens…
CVSS 3.0MEDIUM 6.6· Network · High privileges · No interaction · EPSS 0.00751 · Published 2017-07-17 · No fix listed CWE-565
Priority LOW 31
An issue was discovered in Cloud Foundry Foundation cf-release versions prior to 250 and CAPI-release versions prior to 1.12.0.
CVSS 3.1MEDIUM 6.5· Network · Low privileges · No interaction · EPSS 0.00974 · Published 2017-06-13 · No fix listed CWE-269
Priority LOW 36
An issue was discovered in Cloud Foundry Foundation cf-release versions prior to v250 and CAPI-release versions prior to v1.12.0.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.01687 · Published 2017-01-13 · No fix listed CWE-532