Priority LOW 24
GFI MailEssentials AI versions prior to 22.4 contain an arbitrary directory existence enumeration vulnerability in the ListServer.IsPathExist() web method exposed at /MailEssentials/pages/MailSecurity/ListServer.aspx/IsP…
CVSS 4.0MEDIUM 5.3· Network · Low privileges · No interaction · EPSS 0.00283 · Published 2026-02-19 · Fixed in 22.4 CWE-203
Priority LOW 23
GFI MailEssentials AI versions prior to 22.4 contain an arbitrary file existence enumeration vulnerability in the ListServer.IsDBExist() web method exposed at /MailEssentials/pages/MailSecurity/ListServer.aspx/IsDBExist.
CVSS 4.0MEDIUM 5.3· Network · Low privileges · No interaction · EPSS 0.00213 · Published 2026-02-19 · Fixed in 22.4 CWE-203
Priority LOW 23
GFI MailEssentials AI versions prior to 22.4 contain a stored cross-site scripting vulnerability in the Local Domains settings page.
CVSS 4.0MEDIUM 5.1· Network · Low privileges · User interaction · EPSS 0.00206 · Published 2026-02-19 · Fixed in 22.4 CWE-79
Priority LOW 23
GFI MailEssentials AI versions prior to 22.4 contain a stored cross-site scripting vulnerability in the Spam Keyword Checking (Subject) conditions interface.
CVSS 4.0MEDIUM 5.1· Network · Low privileges · User interaction · EPSS 0.00206 · Published 2026-02-19 · Fixed in 22.4 CWE-79
Priority LOW 23
GFI MailEssentials AI versions prior to 22.4 contain a stored cross-site scripting vulnerability in the Spam Keyword Checking (Body) conditions interface.
CVSS 4.0MEDIUM 5.1· Network · Low privileges · User interaction · EPSS 0.00206 · Published 2026-02-19 · Fixed in 22.4 CWE-79
Priority LOW 23
GFI MailEssentials AI versions prior to 22.4 contain a stored cross-site scripting vulnerability in the Anti-Spoofing configuration page.
CVSS 4.0MEDIUM 5.1· Network · Low privileges · User interaction · EPSS 0.00206 · Published 2026-02-19 · Fixed in 22.4 CWE-79
Priority LOW 23
GFI MailEssentials AI versions prior to 22.4 contain a stored cross-site scripting vulnerability in the Sender Policy Framework Email Exceptions interface.
CVSS 4.0MEDIUM 5.1· Network · Low privileges · User interaction · EPSS 0.00194 · Published 2026-02-19 · Fixed in 22.4 CWE-79
Priority LOW 23
GFI MailEssentials AI versions prior to 22.4 contain a stored cross-site scripting vulnerability in the Sender Policy Framework IP Exceptions interface.
CVSS 4.0MEDIUM 5.1· Network · Low privileges · User interaction · EPSS 0.00206 · Published 2026-02-19 · Fixed in 22.4 CWE-79
Priority LOW 23
GFI MailEssentials AI versions prior to 22.4 contain a stored cross-site scripting vulnerability in the URI DNS Blocklist configuration page.
CVSS 4.0MEDIUM 5.1· Network · Low privileges · User interaction · EPSS 0.00194 · Published 2026-02-19 · Fixed in 22.4 CWE-79
Priority LOW 23
GFI MailEssentials AI versions prior to 22.4 contain a stored cross-site scripting vulnerability in the IP DNS Blocklist configuration page.
CVSS 4.0MEDIUM 5.1· Network · Low privileges · User interaction · EPSS 0.00206 · Published 2026-02-19 · Fixed in 22.4 CWE-79
Priority LOW 23
GFI MailEssentials AI versions prior to 22.4 contain a stored cross-site scripting vulnerability in the IP Blocklist management page.
CVSS 4.0MEDIUM 5.1· Network · Low privileges · User interaction · EPSS 0.00206 · Published 2026-02-19 · Fixed in 22.4 CWE-79
Priority LOW 23
GFI MailEssentials AI versions prior to 22.4 contain a stored cross-site scripting vulnerability in the POP2Exchange configuration endpoint.
CVSS 4.0MEDIUM 5.1· Network · Low privileges · User interaction · EPSS 0.00206 · Published 2026-02-19 · Fixed in 22.4 CWE-79
Priority LOW 23
GFI MailEssentials AI versions prior to 22.4 contain a stored cross-site scripting vulnerability in the Perimeter SMTP Servers configuration page.
CVSS 4.0MEDIUM 5.1· Network · Low privileges · User interaction · EPSS 0.00206 · Published 2026-02-19 · Fixed in 22.4 CWE-79
Priority LOW 23
GFI MailEssentials AI versions prior to 22.4 contain a stored cross-site scripting vulnerability in the Mail Monitoring rule creation endpoint.
CVSS 4.0MEDIUM 5.1· Network · Low privileges · User interaction · EPSS 0.00206 · Published 2026-02-19 · Fixed in 22.4 CWE-79
Priority LOW 23
GFI MailEssentials AI versions prior to 22.4 contain a stored cross-site scripting vulnerability in the Anti-Spam Whitelist management interface.
CVSS 4.0MEDIUM 5.1· Network · Low privileges · User interaction · EPSS 0.00206 · Published 2026-02-19 · Fixed in 22.4 CWE-79
Priority LOW 23
GFI MailEssentials AI versions prior to 22.4 contain a stored cross-site scripting vulnerability in the Advanced Content Filtering rule creation workflow.
CVSS 4.0MEDIUM 5.1· Network · Low privileges · User interaction · EPSS 0.00206 · Published 2026-02-19 · Fixed in 22.4 CWE-79
Priority LOW 23
GFI MailEssentials AI versions prior to 22.4 contain a stored cross-site scripting vulnerability in the Attachment Filtering rule creation workflow.
CVSS 4.0MEDIUM 5.1· Network · Low privileges · User interaction · EPSS 0.00206 · Published 2026-02-19 · Fixed in 22.4 CWE-79
Priority LOW 23
GFI MailEssentials AI versions prior to 22.4 contain a stored cross-site scripting vulnerability in the Keyword Filtering rule creation workflow.
CVSS 4.0MEDIUM 5.1· Network · Low privileges · User interaction · EPSS 0.00206 · Published 2026-02-19 · Fixed in 22.4 CWE-79
Priority HIGH 73
GFI MailEssentials prior to version 21.8 is vulnerable to a .NET deserialization issue.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.00963 · Published 2025-04-28 · Fixed in 21.8 CWE-502
Priority LOW 30
GFI MailEssentials prior to version 21.8 is vulnerable to an XML External Entity (XXE) issue.
CVSS 3.1MEDIUM 6.5· Network · Low privileges · No interaction · EPSS 0.00729 · Published 2025-04-28 · Fixed in 21.8 CWE-611
Priority HIGH 69
GFI MailEssentials prior to version 21.8 is vulnerable to a local privilege escalation issue.
CVSS 3.1HIGH 7.8· Local · Low privileges · No interaction · EPSS 0.00327 · Published 2025-04-28 · Fixed in 21.8 CWE-502
Priority MEDIUM 48
A bug in the HTML parser in a certain Microsoft HTML library, as used in various third party products, may allow remote attackers to cause a denial of service via certain strings, as reported in GFI MailEssentials for Ex…
CVSS 2.0HIGH 10.0· Network · No auth · Interaction — · EPSS 0.0247 · Published 2005-01-06 · No fix listed