Priority LOW 37
Cross-Site Request Forgery (CSRF) vulnerability in Stylemix MasterStudy LMS masterstudy-lms-learning-management-system allows Cross Site Request Forgery.This issue affects MasterStudy LMS: from n/a through <= 3.2.1.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00214 · Published 2025-01-02 · No fix listed CWE-352
Priority MEDIUM 48
Missing Authorization vulnerability in StylemixThemes MasterStudy LMS allows Exploiting Incorrectly Configured Access Control Security Levels.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00406 · Published 2024-11-01 · No fix listed CWE-862
Priority HIGH 80
The MasterStudy LMS WordPress Plugin WordPress plugin before 3.3.24 does not prevent students from creating instructor accounts, which could be used to get access to functionalities they shouldn't have.
CVSS 3.1CRITICAL 9.1· Network · No auth · No interaction · EPSS 0.00493 · Published 2024-07-22 · Fixed in 3.3.24
Priority LOW 28
The MasterStudy LMS WordPress Plugin – for Online Courses and Education plugin for WordPress is vulnerable to unauthorized access, modification, and loss of data due to a missing capability check on several functions in…
CVSS 3.1MEDIUM 6.3· Network · Low privileges · No interaction · EPSS 0.00384 · Published 2024-05-02 · No fix listed CWE-862
Priority MEDIUM 57
The MasterStudy LMS plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 3.3.3 via the 'template' parameter.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.05018 · Published 2024-04-09 · No fix listed CWE-98
Priority LOW 20
The MasterStudy LMS plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the search_posts function in all versions up to, and including, 3.2.13.
CVSS 3.1MEDIUM 4.3· Network · Low privileges · No interaction · EPSS 0.00468 · Published 2024-04-09 · No fix listed CWE-862
Priority MEDIUM 46
The MasterStudy LMS plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 3.3.0 via the 'modal' parameter.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.0154 · Published 2024-03-29 · No fix listed CWE-98
Priority MEDIUM 50
The MasterStudy LMS plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 3.3.1.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00834 · Published 2024-03-29 · No fix listed CWE-266
Priority MEDIUM 40
The MasterStudy LMS WordPress Plugin – for Online Courses and Education plugin for WordPress is vulnerable to Information Exposure in versions up to, and including, 3.2.10.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00802 · Published 2024-03-13 · No fix listed CWE-200
Priority CRITICAL 88
The MasterStudy LMS WordPress Plugin – for Online Courses and Education plugin for WordPress is vulnerable to union based SQL Injection via the 'user' parameter of the /lms/stm-lms/order/items REST route in all versions…
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.77729 · Published 2024-02-17 · No fix listed CWE-89
Priority HIGH 72
The MasterStudy LMS WordPress Plugin WordPress plugin before 3.0.18 does not have proper checks in place during registration allowing anyone to register on the site as an instructor.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.06235 · Published 2023-09-11 · Fixed in 3.0.18
Priority LOW 30
Broken Access Control vulnerability in StylemixThemes MasterStudy LMS WordPress Plugin – for Online Courses and Education plugin <= 3.0.8 versions allows any logged-in users, such as subscribers to view the "Orders" of t…
CVSS 3.1MEDIUM 6.5· Network · Low privileges · No interaction · EPSS 0.00555 · Published 2023-06-22 · No fix listed CWE-862
Priority LOW 29
Auth. (contributor+) Stored Cross-Site Scripting (XSS) vulnerability in StylemixThemes MasterStudy LMS WordPress Plugin – for Online Courses and Education plugin <= 3.0.7 versions.
CVSS 3.1MEDIUM 6.5· Network · Low privileges · User interaction · EPSS 0.00377 · Published 2023-06-22 · No fix listed CWE-79
Priority HIGH 84
The MasterStudy LMS WordPress plugin before 2.7.6 does to validate some parameters given when registering a new account, allowing unauthenticated users to register as an admin
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.85334 · Published 2022-03-07 · Fixed in 2.7.6 CWE-269