Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
2 selected

7 records

TI-2025-05347 CVE-2025-5921 · GHSA-77fc-r534-vggp

SureForms < 1.7.2 - Reflected XSS

Priority MEDIUM 59

The SureForms WordPress plugin before 1.7.2 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against both authenticated and u…

CVSS 3.1MEDIUM 5.8 Network No auth User interaction EPSS 0.00205 Published 2025-08-01 Fixed in 1.7.2 CWE-79
Priority LOW 39

The SureForms – Drag and Drop Form Builder for WordPress plugin for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the delete_entry_files() function in all versions up to,…

CVSS 3.1HIGH 8.1 Network No auth User interaction EPSS 0.01048 Published 2025-07-09 No fix listed CWE-73
Priority LOW 36

The SureForms – Drag and Drop Form Builder for WordPress plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 1.7.3 via the use of file_exists() in the delete_entry_files() fun…

CVSS 3.1HIGH 7.5 Network No auth User interaction EPSS 0.00581 Published 2025-07-09 No fix listed CWE-502
TI-2025-03086 CVE-2025-3514 · GHSA-2954-4rrv-2pfp

SureForms < 1.4.4 - Admin+ Stored XSS

Priority MEDIUM 50

The SureForms WordPress plugin before 1.4.4 does not sanitise and escape some of its Form settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfilt…

CVSS 3.1LOW 3.5 Network High privileges User interaction EPSS 0.00272 Published 2025-05-02 Fixed in 1.4.4 CWE-79
TI-2025-03085 CVE-2025-3513 · GHSA-2qrm-36rr-ffj3

SureForms < 1.4.4 - Admin+ Stored XSS

Priority MEDIUM 50

The SureForms WordPress plugin before 1.4.4 does not sanitise and escape some of its Form settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfilt…

CVSS 3.1LOW 3.5 Network High privileges User interaction EPSS 0.00314 Published 2025-05-02 Fixed in 1.4.4 CWE-79
Priority MEDIUM 56

The SureForms WordPress plugin before 1.4.4 does not have proper authorisation check when updating its settings via the REST API, which could allow Contributor and above roles to perform such action

CVSS 3.1MEDIUM 4.9 Network High privileges No interaction EPSS 0.00361 Published 2025-04-30 Fixed in 1.4.4
Priority LOW 30

The SureForms – Drag and Drop Form Builder for WordPress plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 1.2.2 via the handle_export_form() function due to a missing capab…

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.00352 Published 2025-01-08 No fix listed CWE-862