Priority LOW 37
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in AmentoTech Workreap Core workreap_core allows Blind SQL Injection.This issue affects Workreap Core: from n/a before 3.…
CVSS 3.1HIGH 8.5· Network · Low privileges · No interaction · EPSS 0.00289 · Published 2026-10-22 · Fixed in 3.4.4 CWE-89
Priority MEDIUM 48
Unauthenticated Privilege Escalation in Doctreat Core <= 1.7.0 versions.
CVSS 3.1CRITICAL 10.0· Network · No auth · No interaction · EPSS 0.00261 · Published 2026-10-06 · No fix listed CWE-266
Priority MEDIUM 49
Unauthenticated Arbitrary File Upload in Doctreat <= 1.7.0 versions.
CVSS 3.1CRITICAL 10.0· Network · No auth · No interaction · EPSS 0.00383 · Published 2026-10-06 · No fix listed CWE-434
Priority MEDIUM 43
Employer / Sales Representative Arbitrary File Upload in Workreap Core <= 3.4.5 versions.
CVSS 3.1CRITICAL 9.9· Network · Low privileges · No interaction · EPSS 0.00434 · Published 2026-10-06 · No fix listed CWE-434
Priority MEDIUM 43
Subscriber Arbitrary File Upload in Taskbot <= 6.6 versions.
CVSS 3.1CRITICAL 9.9· Network · Low privileges · No interaction · EPSS 0.00434 · Published 2026-10-06 · No fix listed CWE-434
Priority MEDIUM 49
Unauthenticated Privilege Escalation in Taskbot <= 6.6 versions.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00437 · Published 2026-10-06 · No fix listed CWE-266
Priority MEDIUM 49
The Doctreat Core plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 1.6.8.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00494 · Published 2026-06-10 · No fix listed CWE-269
Priority MEDIUM 50
Authentication Bypass Using an Alternate Path or Channel vulnerability in AmentoTech Workreap Core workreap_core allows Authentication Abuse.This issue affects Workreap Core: from n/a through <= 3.4.1.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00607 · Published 2026-01-22 · No fix listed CWE-288
Priority LOW 37
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in AmentoTech Workreap (theme's plugin) workreap allows SQL Injection.This issue affects Workreap (theme's plugin): from…
CVSS 3.1HIGH 8.5· Network · Low privileges · No interaction · EPSS 0.00356 · Published 2026-01-08 · No fix listed CWE-89
Priority LOW 29
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in AmentoTech Tuturn allows Path Traversal.This issue affects Tuturn: from n/a before 3.6.
CVSS 3.1MEDIUM 6.5· Network · Low privileges · No interaction · EPSS 0.00351 · Published 2025-12-18 · Fixed in 3.6 CWE-22
Priority MEDIUM 49
Authentication Bypass Using an Alternate Path or Channel vulnerability in AmentoTech Tuturn allows Authentication Abuse.This issue affects Tuturn: from n/a before 3.6.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00419 · Published 2025-12-18 · Fixed in 3.6 CWE-288
Priority LOW 34
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in AmentoTech Workreap (theme's plugin) workreap allows Path Traversal.This issue affects Workreap (theme's plugin): from n/a t…
CVSS 3.1HIGH 7.7· Network · Low privileges · No interaction · EPSS 0.00429 · Published 2025-10-22 · No fix listed CWE-22
Priority LOW 31
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in AmentoTech Doctreat doctreat allows Reflected XSS.This issue affects Doctreat: from n/a through <= 1.6.7.
CVSS 3.1HIGH 7.1· Network · No auth · User interaction · EPSS 0.0025 · Published 2025-10-22 · No fix listed CWE-79
Priority LOW 28
Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in AmentoTech Doctreat doctreat allows Code Injection.This issue affects Doctreat: from n/a through <= 1.6.7.
CVSS 3.1MEDIUM 6.3· Network · Low privileges · No interaction · EPSS 0.00268 · Published 2025-10-22 · No fix listed CWE-80
Priority LOW 34
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in AmentoTech Taskbot taskbot allows Path Traversal.This issue affects Taskbot: from n/a through <= 6.4.
CVSS 3.1HIGH 7.7· Network · Low privileges · No interaction · EPSS 0.00429 · Published 2025-10-22 · No fix listed CWE-22
Priority MEDIUM 49
The Workreap plugin for WordPress, used by the Workreap - Freelance Marketplace WordPress Theme, is vulnerable to authentication bypass in all versions up to, and including, 3.3.1.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00478 · Published 2025-06-12 · No fix listed CWE-288
Priority MEDIUM 41
The Workreap plugin for WordPress, used by the Workreap - Freelance Marketplace WordPress Theme, is vulnerable to arbitrary file uploads due to missing file type validation in the 'workreap_temp_upload_to_media' function…
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.00619 · Published 2025-06-12 · No fix listed CWE-434
Priority LOW 37
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in AmentoTech WP Guppy wp-guppy allows SQL Injection.This issue affects WP Guppy: from n/a through <= 4.3.3.
CVSS 3.1HIGH 8.5· Network · Low privileges · No interaction · EPSS 0.00413 · Published 2025-06-09 · No fix listed CWE-89
Priority MEDIUM 49
The Workreap plugin for WordPress is vulnerable to privilege escalation via account takeover in all versions up to, and including, 3.2.5.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00435 · Published 2025-03-12 · No fix listed CWE-288
Priority MEDIUM 62
The Workreap WordPress theme before 2.6.4 does not verify that an addon service belongs to the user issuing the request, or indeed that it is an addon service, when processing the workreap_addons_service_remove action, a…
CVSS 3.1MEDIUM 6.5· Network · Low privileges · No interaction · EPSS 0.00623 · Published 2022-12-26 · Fixed in 2.6.4
Priority HIGH 66
The Workreap WordPress theme before 2.6.3 has a vulnerability with the notifications feature as it's possible to read any user's notification (employer or freelancer) as the notification ID is brute-forceable.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00839 · Published 2022-12-05 · Fixed in 2.6.3
Priority LOW 38
The Workreap WordPress theme before 2.2.2 had several AJAX actions missing authorization checks to verify that a user was authorized to perform critical operations such as modifying or deleting objects.
CVSS 3.1HIGH 8.1· Network · Low privileges · No interaction · EPSS 0.01251 · Published 2021-08-09 · Fixed in 2.2.2 CWE-283
Priority LOW 36
Several AJAX actions available in the Workreap WordPress theme before 2.2.2 lacked CSRF protections, as well as allowing insecure direct object references that were not validated.
CVSS 3.1HIGH 8.1· Network · No auth · User interaction · EPSS 0.00646 · Published 2021-08-09 · Fixed in 2.2.2 CWE-283
Priority HIGH 76
The Workreap WordPress theme before 2.2.2 AJAX actions workreap_award_temp_file_uploader and workreap_temp_file_uploader did not perform nonce checks, or validate that the request is from a valid user in any other way.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.60113 · Published 2021-08-09 · Fixed in 2.2.2 CWE-434