Priority MEDIUM 40
Anchor CMS through 0.12.7 fails to enforce role-based access control in admin user-management endpoints, allowing any authenticated low-privilege user to create administrator accounts or modify existing ones.
CVSS 4.0HIGH 8.7· Network · Low privileges · No interaction · EPSS 0.00523 · Published 2026-09-10 · No fix listed CWE-862
Priority MEDIUM 58
A stored cross-site scripting (XSS) vulnerability in Anchor CMS v0.12.7 allows attackers to inject malicious JavaScript via the page description field in the page creation interface (/admin/pages/add).
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00645 · Published 2025-06-09 · No fix listed CWE-79
Priority HIGH 73
Cross Site Scripting vulnerability in Anchor CMS v.0.12.7 allows a remote attacker to execute arbitrary code via a crafted .pdf file.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.16612 · Published 2024-06-24 · No fix listed CWE-80
Priority HIGH 66
Anchor CMS v0.12.7 was discovered to contain a Cross-Site Request Forgery (CSRF) via /anchor/admin/users/delete/2.
CVSS 3.1HIGH 7.4· Network · Low privileges · No interaction · EPSS 0.00251 · Published 2024-03-22 · No fix listed CWE-352
Priority MEDIUM 46
Anchor CMS v0.12.7 was discovered to contain a Cross-Site Request Forgery (CSRF) via /anchor/admin/categories/delete/2.
CVSS 3.1LOW 2.4· Network · High privileges · User interaction · EPSS 0.00255 · Published 2024-03-22 · No fix listed CWE-352
Priority LOW 21
Anchor CMS v0.12.7 was discovered to contain a Cross-Site Request Forgery (CSRF) via the component anchor/routes/posts.php.
CVSS 3.1MEDIUM 4.5· Network · High privileges · User interaction · EPSS 0.00401 · Published 2022-03-24 · No fix listed CWE-352
Priority LOW 25
A cross-site scripting (XSS) vulnerability in the Create Post function of Anchor CMS v0.12.7 allows attackers to execute arbitrary web scripts or HTML.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00617 · Published 2022-02-01 · No fix listed CWE-79
Priority LOW 29
Cross Site Scripting (XSS) vulnerability exits in Anchor CMS <=0.12.7 in posts.php.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.0077 · Published 2021-12-15 · No fix listed CWE-79
Priority MEDIUM 52
A CSRF vulnerability exists in Anchor CMS 0.12.7 anchor/views/users/edit.php that can change the Delete admin users.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.12428 · Published 2021-01-19 · No fix listed CWE-352
Priority LOW 23
Anchor 0.12.7 allows admins to cause XSS via crafted post content.
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00564 · Published 2020-04-23 · No fix listed CWE-79
Priority HIGH 80
An issue was discovered in config/error.php in Anchor 0.12.3.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.7183 · Published 2018-02-19 · Fixed in 0.12.7 CWE-200
Priority LOW 28
Cross-site scripting (XSS) vulnerability in anchor-cms before 0.9-dev.
CVSS 3.0MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00652 · Published 2017-09-07 · No fix listed CWE-79
Priority LOW 38
system/session/drivers/cookie.php in Anchor CMS 0.9.x allows remote attackers to conduct PHP object injection attacks and execute arbitrary PHP code via a crafted serialized object in a cookie.
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.02501 · Published 2015-10-05 · No fix listed CWE-94
Priority LOW 22
models/comment.php in Anchor CMS 0.9.2 and earlier allows remote attackers to inject arbitrary headers into mail messages via a crafted Host: header.
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.01007 · Published 2014-12-02 · No fix listed CWE-79