Priority MEDIUM 61
Chainlit 2.12.0 contains a server-side request forgery vulnerability that allows unauthenticated attackers to bypass path-scoped MCP allowed_urls entries because validate_mcp_url does not reject the semicolon character.
CVSS 4.0MEDIUM 6.3· Network · No auth · No interaction · EPSS 0.00221 · Published 2026-11-02 · No fix listed CWE-918
Priority MEDIUM 45
Chainlit through 2.12.0 fails to validate the client-supplied socket.io sessionId parameter, allowing unauthenticated attackers to traverse filesystem paths by injecting absolute or relative path sequences.
CVSS 4.0HIGH 8.8· Network · No auth · No interaction · EPSS 0.00598 · Published 2026-09-09 · No fix listed CWE-22
Priority MEDIUM 60
Chainlit through 2.12.0 fails to validate ownership of feedback records in PUT and DELETE endpoints.
CVSS 4.0MEDIUM 6.0· Network · Low privileges · No interaction · EPSS 0.0034 · Published 2026-08-28 · No fix listed CWE-639
Priority LOW 38
Chainlit is a Python framework for building production-ready conversational AI applications.
CVSS 3.1HIGH 7.2· Network · No auth · No interaction · EPSS 0.00434 · Published 2026-08-25 · Fixed in 2.12.0 CWE-918
Priority HIGH 82
Chainlit is a Python framework for building production-ready conversational AI applications.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01086 · Published 2026-08-25 · Fixed in 2.12.0 CWE-78
Priority MEDIUM 40
Chainlit before 2.10.1 contains a session hijacking vulnerability that allows unauthenticated attackers to restore and inherit authenticated user sessions by presenting a valid sessionId during WebSocket session restorat…
CVSS 4.0HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.00417 · Published 2026-06-22 · Fixed in 2.10.1 CWE-862
Priority MEDIUM 50
Chainlit versions prior to 2.9.4 contain a server-side request forgery (SSRF) vulnerability in the /project/element update flow when configured with the SQLAlchemy data layer backend.
CVSS 4.0HIGH 8.3· Network · Low privileges · No interaction · EPSS 0.05174 · Published 2026-01-19 · Fixed in 2.9.4 CWE-918
Priority MEDIUM 64
Chainlit versions prior to 2.9.4 contain an arbitrary file read vulnerability in the /project/element update flow.
CVSS 4.0HIGH 7.1· Network · Low privileges · No interaction · EPSS 0.09724 · Published 2026-01-19 · Fixed in 2.9.4 CWE-22
Priority LOW 11
Chainlit versions prior to 2.8.5 contain an authorization bypass through user-controlled key vulnerability.
CVSS 4.0LOW 2.3· Network · Low privileges · No interaction · EPSS 0.00222 · Published 2026-01-14 · Fixed in 2.8.5 CWE-639