Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
1 selected

84 records

Priority MEDIUM 40

The Nginx routing configuration for Cloud Controller blocks unauthenticated access to /internal/v4/ and /internal/v5/ endpoints but omits an equivalent deny rule for /internal/v3/.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.00232 Published 2026-10-30 Fixed in v1.247.0, 60.7.0 CWE-284
Priority LOW 13

A user with SpaceDeveloper privileges could modify the URL of a space-scoped broker without altering its credentials, enabling extraction of existing broker credentials by redirecting them to a broker under their control…

CVSS 3.1LOW 2.7 Network High privileges No interaction EPSS 0.00179 Published 2026-10-30 Fixed in v1.248.0, 60.9.0 CWE-639
Priority LOW 30

A denial-of-service vulnerability exists in UAA's private_key_jwt client-authentication mechanism.

CVSS 4.0MEDIUM 6.9 Network High privileges No interaction EPSS 0.00287 Published 2026-10-30 Fixed in 79.9.0, 60.11.0 CWE-400
Priority LOW 30

Insufficient verification of data authenticity (CWE-345) in the external OIDC login callback in Cloud Foundry UAA v4.5.0 to v79.6.0 (inclusive) allows an authenticated UAA user to bypass the OAuth authorization-code exch…

CVSS 4.0MEDIUM 6.5 Network No auth User interaction EPSS 0.00185 Published 2026-10-06 Fixed in 79.7.0, 60.5.0 CWE-345
Priority LOW 35

Improper authentication (CWE-287) in the OAuth token endpoint in Cloud Foundry UAA allows a remote, authenticated attacker holding a valid user access token to obtain a fully-privileged client_credentials token for the O…

CVSS 4.0HIGH 7.6 Network Low privileges No interaction EPSS 0.00413 Published 2026-10-06 Fixed in 79.7.0, 60.5.0 CWE-287
TI-2026-29663 CVE-2026-41012 · GHSA-3rqq-7767-6jq7

BOSH vSphere CPI Improper Cert Validation

Priority LOW 34

Traffic interception vulnerability in BOSH Director vCenter CPI allows attackers positioned between BOSH Director and vCenter to impersonate vCenter REST API and capture administrator credentials via HTTP Basic auth, lea…

CVSS 3.1HIGH 7.7 Local No auth User interaction EPSS 0.001 Published 2026-08-29 Fixed in 98.0.6 CWE-295
Priority MEDIUM 40

Improper handling of case sensitivity (CWE-178) in the identity zone authorization check in the Identity Zone Endpoint in Cloud Foundry UAA allows a remote authenticated attacker holding only the zones.write authority to…

CVSS 3.1HIGH 8.7 Network High privileges No interaction EPSS 0.00528 Published 2026-08-25 Fixed in 78.16.0, 57.0.0 CWE-178
Priority MEDIUM 40

Cloud Foundry UAA incorrectly treated XML encryption to the Service Provider (confidentiality) as a substitute for XML signatures from the Identity Provider (authenticity) in two SAML flows: the OAuth 2.0 SAML2 bearer gr…

CVSS 3.1CRITICAL 9.0 Network No auth No interaction EPSS 0.00131 Published 2026-06-11 Fixed in 78.14.0, 57.0.0 CWE-347
TI-2026-18259 CVE-2026-22734 · GHSA-vp68-f85j-5gw3

Cloud Foundry UAA SAML 2.0 Signature Bypass

Priority MEDIUM 43

Cloud Foundry UUA is vulnerable to a bypass that allows an attacker to obtain a token for any user and gain access to UAA-protected systems.

CVSS 3.1HIGH 8.6 Network No auth No interaction EPSS 0.00364 Published 2026-04-16 No fix listed CWE-290
TI-2025-16156 CVE-2025-22246 · GHSA-f42p-pxc9-254g

CVE-2025-22246 – UAA Private Key Exposure

Priority LOW 32

Cloud Foundry UAA release versions from v77.21.0 to v7.31.0 are vulnerable to a private key exposure in logs.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00204 Published 2025-05-13 Fixed CWE-532
TI-2025-16127 CVE-2025-22216 · GHSA-g68x-c5mc-5vwr

CVE-2025-22216 UAA Missing Zone Validation

Priority LOW 24

A UAA configured with multiple identity zones, does not properly validate session information across those zones.

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.002 Published 2025-01-31 Fixed in 77.20.2, 77.25.0 CWE-384
Priority MEDIUM 42

When deploying Cloud Foundry together with the haproxy-boshrelease and using a non default configuration, it might be possible to craft HTTP requests that bypass mTLS authentication to Cloud Foundry applications.

CVSS 3.1CRITICAL 9.1 Network No auth No interaction EPSS 0.00545 Published 2024-07-03 Fixed in 0.299.0 CWE-290
TI-2024-14866 CVE-2024-22279 · GHSA-3cff-hppc-4g4r

GoRouter Denial of Service Attack

Priority LOW 33

Improper handling of requests in Routing Release > v0.273.0 and <= v0.297.0 allows an unauthenticated attacker to degrade the service availability of the Cloud Foundry deployment if performed at scale.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00402 Published 2024-06-10 No fix listed CWE-444
TI-2023-16927 CVE-2023-34061 · GHSA-xr94-cv8c-7r6v

CVE-2023-34061 – Gorouter route pruning

Priority MEDIUM 40

Cloud Foundry routing release versions from v0.163.0 to v0.283.0 are vulnerable to a DOS attack.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00538 Published 2024-01-12 Fixed in 0.284.0, 33.6.0 CWE-400
Priority LOW 30

Vulnerability in Cloud Foundry Notifications, Cloud Foundry SMB-volume release, Cloud FOundry cf-nfs-volume release.This issue affects Notifications: All versions prior to 63; SMB-volume release: All versions prior to 3.…

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.00541 Published 2023-06-16 Fixed in 63, 3.1.19 CWE-532
Priority LOW 35

CAPI (Cloud Controller) versions prior to 1.101.0 are vulnerable to a denial-of-service attack in which an unauthenticated malicious attacker can send specially-crafted YAML files to certain endpoints, causing the YAML p…

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.01145 Published 2020-12-02 Fixed in 1.101.0, 15.0.0 CWE-400
Priority LOW 36

Cloud Foundry Routing (Gorouter) versions prior to 0.206.0 allow a malicious developer with "cf push" access to cause denial-of-service to the CF cluster by pushing an app that returns specially crafted HTTP responses th…

CVSS 3.1HIGH 7.7 Network Low privileges No interaction EPSS 0.01183 Published 2020-09-03 Fixed in 0.206.0, 13.15.0 CWE-754
Priority LOW 21

Cloud Foundry CAPI (Cloud Controller) versions prior to 1.98.0 allow authenticated users having only the "cloud_controller.read" scope, but no roles in any spaces, to list all droplets in all spaces (whereas they should…

CVSS 3.1MEDIUM 4.3 Network Low privileges No interaction EPSS 0.00575 Published 2020-09-03 Fixed in 1.98.0, 13.17.0 CWE-863
Priority MEDIUM 40

Cloud Foundry CAPI (Cloud Controller), versions prior to 1.97.0, when used in a deployment where an app domain is also the system domain (which is true in the default CF Deployment manifest), were vulnerable to developer…

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.00986 Published 2020-08-21 Fixed in 1.97.0, 13.12.0 CWE-732
Load more