Priority MEDIUM 60
A stored cross-site scripting (XSS) vulnerability in the Media module of Piranha CMS v12.1 allows attackers to execute arbitrary web scripts or HTML via injecting a crafted payload into the Name field.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00213 · Published 2025-12-22 · No fix listed CWE-79
Priority MEDIUM 60
A stored cross-site scripting (XSS) vulnerability in the Page Settings module of Piranha CMS v12.1 allows attackers to execute arbitrary web scripts or HTML via injecting a crafted payload into the Excerpt field.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00213 · Published 2025-12-22 · No fix listed CWE-79
Priority MEDIUM 60
A stored cross-site scripting (XSS) vulnerability in the /manager/pages component of Piranha CMS v12.0 allows attackers to execute arbitrary web scripts or HTML via creating a page and injecting a crafted payload into th…
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00289 · Published 2025-10-23 · No fix listed CWE-79
Priority MEDIUM 63
PiranhaCMS 12.0 allows stored XSS in the Text content block of Standard and Standard Archive Pages via /manager/pages, enabling execution of arbitrary JavaScript in another user s browser.
CVSS 3.1MEDIUM 6.8· Network · Low privileges · User interaction · EPSS 0.00326 · Published 2025-09-26 · No fix listed CWE-79
Priority MEDIUM 55
A file upload functionality in Piranha CMS 11.1 allows authenticated remote attackers to upload a crafted PDF file to /manager/media.
CVSS 3.1MEDIUM 4.7· Network · No auth · User interaction · EPSS 0.00507 · Published 2024-12-20 · No fix listed CWE-79
Priority MEDIUM 55
A stored cross-site scripting (XSS) vulnerability in Piranha CMS 11.1 allows remote attackers to execute arbitrary JavaScript in the web browser of a user, by creating a page via the /manager/pages and then adding a mark…
CVSS 3.1MEDIUM 4.7· Network · No auth · User interaction · EPSS 0.00455 · Published 2024-12-20 · No fix listed CWE-79
Priority LOW 35
A vulnerability has been found in OmniSharp csharp-language-server-protocol up to 0.19.6 and classified as problematic.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00886 · Published 2023-07-17 · No fix listed CWE-400
Priority HIGH 68
In PiranhaCMS, versions 4.0.0-alpha1 to 9.2.0 are vulnerable to cross-site request forgery (CSRF) when performing various actions supported by the management system, such as deleting a user, deleting a role, editing a po…
CVSS 3.1HIGH 8.1· Network · No auth · User interaction · EPSS 0.00456 · Published 2021-11-16 · Fixed in 10.0-alpha1 CWE-352
Priority MEDIUM 58
In PiranhaCMS, versions 7.0.0 to 9.1.1 are vulnerable to stored XSS due to the page title improperly sanitized.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.0065 · Published 2021-10-25 · Fixed in 9.2.0 CWE-79