Priority HIGH 72
FileRun before 2026.3.0 contains a PHP object injection vulnerability that allows authenticated attackers to execute arbitrary code by exploiting incorrect options passed to unserialize() in the Perms::getPerms() method,…
CVSS 4.0HIGH 8.6· Network · High privileges · No interaction · EPSS 0.00781 · Published 2026-09-10 · Fixed in 2026.3.0 CWE-502
Priority HIGH 72
FileRun before 2026.3.0 contains a SQL injection vulnerability that allows delegated or simple administrators to execute arbitrary SQL by submitting the description parameter as an array, causing the getValuesString() me…
CVSS 4.0HIGH 8.6· Network · High privileges · No interaction · EPSS 0.00622 · Published 2026-09-10 · Fixed in 2026.3.0 CWE-89
Priority HIGH 72
FileRun before 2026.3.0 contains an OS command injection vulnerability caused by a no-op redefinition of escapeshellcmd() in CLI.php that strips shell-metacharacter escaping, allowing attacker-controlled input to reach a…
CVSS 4.0HIGH 8.6· Network · High privileges · No interaction · EPSS 0.02237 · Published 2026-09-10 · Fixed in 2026.3.0 CWE-78
Priority MEDIUM 45
FileRun before 2026.3.0 contains an OS command injection vulnerability in the PhotoProofSheet handler that allows authenticated users with upload permission to execute arbitrary commands by uploading files with shell met…
CVSS 4.0HIGH 8.7· Network · Low privileges · No interaction · EPSS 0.0271 · Published 2026-09-10 · Fixed in 2026.3.0 CWE-78
Priority MEDIUM 44
FileRun up to and including version 2026.2.0 contains an OS command injection vulnerability that allows authenticated attackers to achieve remote code execution by uploading a file with a malicious filename containing sh…
CVSS 4.0HIGH 8.7· Network · Low privileges · No interaction · EPSS 0.02539 · Published 2026-08-11 · Fixed in 2026.2.1 CWE-78
Priority MEDIUM 43
FileRun 20220519 allows SQL Injection via the "dir" parameter in a /?module=users§ion=cpanel&page=list request.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00628 · Published 2023-12-22 · No fix listed CWE-89
Priority MEDIUM 47
FileRun (version 2017.09.18 and below) suffers from a remote SQL injection vulnerability due to a failure to sanitize input in the metafield parameter inside the metasearch module (under the search function).
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.02624 · Published 2017-09-29 · No fix listed CWE-89
Priority LOW 29
Multiple cross-site scripting (XSS) vulnerabilities in index.php in FileRun 1.0 and earlier allow remote attackers to inject arbitrary web script or HTML via the (1) page, (2) module, or (3) section parameter.
CVSS 2.0MEDIUM 5.8· Network · No auth · Interaction — · EPSS 0.01645 · Published 2007-05-02 · No fix listed
Priority LOW 36
SQL injection vulnerability in index.php in FileRun 1.0 and earlier allows remote attackers to execute arbitrary SQL commands via the fid parameter.
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.01822 · Published 2007-05-02 · No fix listed