Priority LOW 30
LogicalDOC Community Edition through 9.3 contains a username enumeration vulnerability that allows unauthenticated attackers to identify valid accounts because the AvatarServlet (/avatar) performs no session validation.
CVSS 4.0MEDIUM 6.9· Network · No auth · No interaction · EPSS 0.00248 · Published 2026-10-12 · No fix listed CWE-204
Priority MEDIUM 44
LogicalDOC Community Edition through 9.3 contains an unauthenticated file upload vulnerability in the UploadServlet that allows remote attackers to write files to disk without a session.
CVSS 4.0HIGH 8.7· Network · No auth · No interaction · EPSS 0.00422 · Published 2026-10-12 · No fix listed CWE-770
Priority LOW 23
LogicalDOC Community Edition through 9.3 contains an improper authorization vulnerability in the PswRecovery servlet that fails to bind password recovery tickets to the requesting user.
CVSS 4.0MEDIUM 5.3· Network · Low privileges · No interaction · EPSS 0.00198 · Published 2026-10-12 · No fix listed CWE-640
Priority LOW 31
LogicalDOC Community Edition through 9.3 contains a missing authorization vulnerability in the ConvertPdf servlet that allows authenticated users to download restricted PDF documents.
CVSS 4.0HIGH 7.1· Network · Low privileges · No interaction · EPSS 0.00238 · Published 2026-10-12 · No fix listed CWE-862
Priority LOW 31
LogicalDOC Community Edition through 9.3 contains a missing authorization vulnerability in the zip-export servlet that allows authenticated users to export restricted folders by supplying a folderId parameter.
CVSS 4.0HIGH 7.1· Network · Low privileges · No interaction · EPSS 0.00257 · Published 2026-10-12 · No fix listed CWE-862
Priority LOW 39
LogicalDOC Community Edition through 9.3 contains a missing authorization vulnerability in SoapDocumentService operations that allows authenticated users to access and modify unauthorized documents.
CVSS 4.0HIGH 8.7· Network · Low privileges · No interaction · EPSS 0.00255 · Published 2026-10-12 · No fix listed CWE-862
Priority LOW 23
LogicalDOC Community Edition through 9.3 contains a server-side request forgery vulnerability in the default-enabled XMLConverter that fetches xml-stylesheet href URLs without scheme or host allowlisting.
CVSS 4.0MEDIUM 5.3· Network · Low privileges · No interaction · EPSS 0.00177 · Published 2026-10-12 · No fix listed CWE-918
Priority MEDIUM 40
LogicalDOC Community Edition through 9.3 contains a code injection vulnerability that allows authenticated users to execute OS commands by submitting Velocity templates in DocumentService.sendAsEmail subject or message f…
CVSS 4.0HIGH 8.7· Network · Low privileges · No interaction · EPSS 0.00393 · Published 2026-10-12 · No fix listed CWE-94
Priority LOW 31
LogicalDOC Community Edition through 9.3 contains an HQL injection vulnerability in DocumentsDataServlet that allows authenticated users to manipulate queries via the unvalidated indexed parameter.
CVSS 4.0HIGH 7.1· Network · Low privileges · No interaction · EPSS 0.00273 · Published 2026-10-12 · No fix listed CWE-89
Priority LOW 31
LogicalDOC Community Edition through 9.3 contains a sql injection vulnerability that allows authenticated users to execute crafted SQL via the firstLetter parameter of TagsDataServlet.
CVSS 4.0HIGH 7.1· Network · Low privileges · No interaction · EPSS 0.00269 · Published 2026-10-12 · No fix listed CWE-89
Priority MEDIUM 64
LogicalDOC Enterprise 7.7.4 contains multiple post-authentication file disclosure vulnerabilities that allow attackers to read arbitrary files through unverified 'suffix' and 'fileVersion' parameters.
CVSS 4.0HIGH 7.1· Network · Low privileges · No interaction · EPSS 0.01129 · Published 2025-12-24 · No fix listed CWE-22
Priority HIGH 73
LogicalDOC Enterprise 7.7.4 contains multiple authenticated OS command execution vulnerabilities that allow attackers to manipulate binary paths when changing system settings.
CVSS 4.0HIGH 8.7· Network · Low privileges · No interaction · EPSS 0.00407 · Published 2025-12-24 · No fix listed CWE-426
Priority MEDIUM 61
A vulnerability was identified in LogicalDOC Community Edition up to 9.2.1.
CVSS 4.0MEDIUM 6.3· Network · No auth · No interaction · EPSS 0.00791 · Published 2025-10-31 · No fix listed CWE-307
Priority MEDIUM 56
A vulnerability was determined in LogicalDOC Community Edition up to 9.2.1.
CVSS 4.0MEDIUM 5.1· Network · Low privileges · User interaction · EPSS 0.00287 · Published 2025-10-31 · No fix listed CWE-79
Priority MEDIUM 56
A security flaw has been discovered in LogicalDOC Community Edition up to 9.2.1.
CVSS 4.0MEDIUM 5.1· Network · Low privileges · User interaction · EPSS 0.00366 · Published 2025-10-19 · No fix listed CWE-79
Priority MEDIUM 44
Logout functionality contains a blind SQL injection that can be exploited by unauthenticated attackers.
CVSS 4.0HIGH 8.7· Network · No auth · No interaction · EPSS 0.00378 · Published 2025-03-14 · No fix listed CWE-89
Priority LOW 28
There is a reflected cross-site scripting (XSS) within JSP files used to control application appearance.
CVSS 4.0MEDIUM 6.4· Network · No auth · User interaction · EPSS 0.00266 · Published 2025-03-14 · No fix listed CWE-79
Priority LOW 32
The API used to interact with documents in the application contains a flaw that allows an authenticated attacker to read the contents of files on the underlying operating system.
CVSS 4.0HIGH 7.1· Network · Low privileges · No interaction · EPSS 0.00467 · Published 2025-03-14 · Fixed in 9.1 CWE-23
Priority MEDIUM 47
The API used to interact with documents in the application contains two endpoints with a flaw that allows an authenticated attacker to write a file with controlled contents to an arbitrary location on the underlying file…
CVSS 4.0HIGH 8.7· Network · Low privileges · No interaction · EPSS 0.00612 · Published 2025-03-14 · Fixed in 9.1 CWE-23
Priority MEDIUM 46
The Automation Scripting functionality can be exploited by attackers to run arbitrary system commands on the underlying operating system.
CVSS 4.0HIGH 8.6· Network · High privileges · No interaction · EPSS 0.00579 · Published 2025-03-14 · Fixed in 9.1 CWE-94
Priority LOW 39
Saved search functionality contains a blind SQL injection that can be exploited by authenticated attackers.
CVSS 4.0HIGH 7.1· Network · Low privileges · No interaction · EPSS 0.00325 · Published 2025-03-14 · Fixed in 9.1 CWE-89
Priority LOW 33
Document history functionality contains a blind SQL injection that can be exploited by authenticated attackers.
CVSS 4.0HIGH 7.1· Network · Low privileges · No interaction · EPSS 0.00325 · Published 2025-03-14 · No fix listed CWE-89
Priority MEDIUM 46
Login functionality contains a blind SQL injection that can be exploited by unauthenticated attackers.
CVSS 4.0HIGH 8.7· Network · No auth · No interaction · EPSS 0.00378 · Published 2025-03-14 · Fixed in 9.1 CWE-89
Priority MEDIUM 58
LogicalDOC Enterprise and Community Edition (CE) are vulnerable to a stored (persistent, or "Type II") cross-site scripting (XSS) condition in the document version comments.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00497 · Published 2023-02-07 · No fix listed CWE-79
Priority MEDIUM 58
LogicalDOC Enterprise and Community Edition (CE) are vulnerable to a stored (persistent, or "Type II") cross-site scripting (XSS) condition in the document file name.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00497 · Published 2023-02-07 · No fix listed CWE-79
Load more