Priority LOW 22
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Piwik PRO allows Cross-Site Scripting (XSS).This issue affects Piwik PRO: from 0.0.0 before 1.3.2.
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00231 · Published 2025-05-21 · Fixed in 1.3.2 CWE-79
Priority LOW 28
The Matomo Analytics – Ethical Stats.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00546 · Published 2024-02-20 · No fix listed CWE-79
Priority LOW 28
The matomo_integration (aka Matomo Integration) extension before 1.3.2 for TYPO3 allows XSS.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00573 · Published 2022-07-12 · Fixed in 1.3.2 CWE-79
Priority MEDIUM 46
The official piwik Docker images before fpm-alpine (Alpine specific) contain a blank password for a root user.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.02274 · Published 2020-12-08 · No fix listed
Priority LOW 30
Cross-site Scripting (XSS) in Piwik before 1.10.1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.01161 · Published 2019-11-20 · No fix listed CWE-79
Priority LOW 30
Cross-site Scripting (XSS) in Piwik before 1.10.1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.01161 · Published 2019-11-20 · No fix listed CWE-79
Priority LOW 30
Cross-site Scripting (XSS) in Piwik before 1.10.1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.01161 · Published 2019-11-20 · No fix listed CWE-79
Priority LOW 22
A full path disclosure vulnerability was discovered in Matomo v3.9.1 where a user can trigger a particular error to discover the full path of Matomo on the disk, because lastError.file is used in plugins/CorePluginsAdmin…
CVSS 3.0MEDIUM 4.3· Network · Low privileges · No interaction · EPSS 0.01211 · Published 2019-05-20 · No fix listed CWE-209
Priority MEDIUM 40
The DisplayTopKeywords function in plugins/Referrers/Controller.php in Piwik before 2.15.0 allows remote attackers to conduct PHP object injection attacks, conduct Server-Side Request Forgery (SSRF) attacks, and execute…
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.03931 · Published 2015-11-16 · No fix listed
Priority LOW 38
Directory traversal vulnerability in core/ViewDataTable/Factory.php in Piwik before 2.15.0 allows remote attackers to include and execute arbitrary local files via the viewDataTable parameter.
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.02956 · Published 2015-11-16 · No fix listed CWE-22
Priority LOW 25
Piwik before 1.11 accepts input from a POST request instead of a GET request in unspecified circumstances, which might allow attackers to obtain sensitive information by leveraging the logging of parameters.
CVSS 2.0MEDIUM 5.0· Network · No auth · Interaction — · EPSS 0.00993 · Published 2013-03-21 · Fixed in 1.11 CWE-20
Priority LOW 22
Cross-site scripting (XSS) vulnerability in Piwik before 1.11 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.00931 · Published 2013-03-21 · Fixed in 1.11 CWE-79
Priority LOW 22
Cross-site scripting (XSS) vulnerability in Piwik before 1.9 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.01148 · Published 2012-11-19 · No fix listed CWE-79
Priority LOW 34
Unspecified vulnerability in Piwik 1.2 through 1.4 allows remote attackers with the view permission to execute arbitrary code via unknown attack vectors.
CVSS 2.0MEDIUM 6.8· Network · No auth · Interaction — · EPSS 0.02268 · Published 2012-09-18 · Fixed in 1.5 CWE-269
Priority LOW 25
Piwik 1.1 allows remote attackers to obtain sensitive information via a direct request to a .php file, which reveals the installation path in an error message, as demonstrated by plugins/Widgetize/Widgetize.php and certa…
CVSS 2.0MEDIUM 5.0· Network · No auth · Interaction — · EPSS 0.01229 · Published 2011-09-24 · No fix listed CWE-200
Priority LOW 26
Piwik before 1.1 does not properly limit the number of files stored under tmp/sessions/, which might allow remote attackers to cause a denial of service (inode consumption) by establishing many sessions.
CVSS 2.0MEDIUM 5.0· Network · No auth · Interaction — · EPSS 0.01653 · Published 2011-01-10 · No fix listed CWE-264
Priority LOW 25
Cookie.php in Piwik before 1.1 does not set the secure flag for the session cookie in an https session, which makes it easier for remote attackers to capture this cookie by intercepting its transmission within an http se…
CVSS 2.0MEDIUM 5.0· Network · No auth · Interaction — · EPSS 0.01281 · Published 2011-01-10 · No fix listed CWE-16
Priority LOW 23
Piwik before 1.1 does not prevent the rendering of the login form inside a frame in a third-party HTML document, which makes it easier for remote attackers to conduct clickjacking attacks via a crafted web site.
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.01381 · Published 2011-01-10 · No fix listed
Priority LOW 31
The Piwik_Common::getIP function in Piwik before 1.1 does not properly determine the client IP address, which allows remote attackers to bypass intended geolocation and logging functionality via (1) use of a private (aka…
CVSS 2.0MEDIUM 6.4· Network · No auth · Interaction — · EPSS 0.01338 · Published 2011-01-10 · No fix listed CWE-264
Priority LOW 23
Multiple cross-site scripting (XSS) vulnerabilities in Piwik before 1.1 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.01562 · Published 2011-01-10 · No fix listed CWE-79
Priority LOW 35
Directory traversal vulnerability in Piwik 0.6 through 0.6.3 allows remote attackers to include arbitrary local files and possibly have unspecified other impact via directory traversal sequences in a crafted data-rendere…
CVSS 2.0MEDIUM 6.8· Network · No auth · Interaction — · EPSS 0.02729 · Published 2010-08-02 · No fix listed CWE-22
Priority LOW 25
Cross-site scripting (XSS) vulnerability in the Login form in Piwik 0.1.6 through 0.5.5 allows remote attackers to inject arbitrary web script or HTML via the form_url parameter.
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.02988 · Published 2010-05-07 · No fix listed CWE-79
Priority MEDIUM 50
The loadContentFromCookie function in core/Cookie.php in Piwik before 0.5 does not validate strings obtained from cookies before calling the unserialize function, which allows remote attackers to execute arbitrary code o…
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.16949 · Published 2009-12-24 · No fix listed CWE-20
Priority HIGH 72
Unrestricted file upload vulnerability in ofc_upload_image.php in Open Flash Chart v2 Beta 1 through v2 Lug Wyrm Charmer, as used in Piwik 0.2.35 through 0.4.3, Woopra Analytics Plugin before 1.4.3.2, and possibly other…
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.75838 · Published 2009-12-22 · No fix listed
Priority LOW 25
Piwik 0.2.32 and earlier stores sensitive information under the web root with insufficient access control, which allows remote attackers to obtain the API key and other sensitive information via a direct request for misc…
CVSS 2.0MEDIUM 5.0· Network · No auth · Interaction — · EPSS 0.01205 · Published 2009-03-25 · No fix listed CWE-264