Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
1 selected

2 records

Priority MEDIUM 40

oapi-codegen 2.0.0 before 2.8.1 contains a code injection vulnerability that allows attackers to inject Go code by supplying non-literal enum entries in integer, number, or boolean schemas.

CVSS 4.0HIGH 8.7 Network No auth User interaction EPSS 0.00422 Published 2026-10-29 Fixed in 2.8.1 CWE-94
Priority LOW 36

oapi-codegen 2.5.0 before 2.8.1 contains a code injection vulnerability that allows attackers to inject Go code by supplying a crafted servers[].x-go-name value emitted unescaped by the server-urls template.

CVSS 4.0HIGH 7.7 Network No auth User interaction EPSS 0.00394 Published 2026-10-29 Fixed in 2.8.1 CWE-94