Priority LOW 39
Cross-site request forgery (CSRF) vulnerability in Opsview before 4.4.1 and Opsview Core before 20130522 allows remote attackers to hijack the authentication of administrators for requests that change the administrator p…
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00542 · Published 2020-01-02 · Fixed in 4.4.1, 20130522 CWE-352
Priority LOW 29
Multiple cross-site scripting (XSS) vulnerabilities in Opsview before 4.4.1 and Opsview Core before 20130522 allow remote attackers to inject arbitrary web script or HTML.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00772 · Published 2020-01-02 · Fixed in 4.4.1, 20130522 CWE-79
Priority LOW 30
The diagnosticsb2ksy parameter of the /rest endpoint in Opsview Monitor before 5.3.1 and 5.4.x before 5.4.2 is vulnerable to Cross-Site Scripting.
CVSS 3.0MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.01311 · Published 2018-09-05 · No fix listed CWE-79
Priority LOW 30
The data parameter of the /settings/api/router endpoint in Opsview Monitor before 5.3.1 and 5.4.x before 5.4.2 is vulnerable to Cross-Site Scripting.
CVSS 3.0MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.01311 · Published 2018-09-05 · No fix listed CWE-79
Priority MEDIUM 41
The web management console of Opsview Monitor 5.4.x before 5.4.2 provides functionality accessible by an authenticated administrator to test notifications that are triggered under certain configurable events.
CVSS 3.0HIGH 7.2· Network · High privileges · No interaction · EPSS 0.06197 · Published 2018-09-05 · No fix listed CWE-78
Priority MEDIUM 40
The /etc/init.d/opsview-reporting-module script that runs at boot time in Opsview Monitor before 5.3.1 and 5.4.x before 5.4.2 invokes a file that can be edited by the nagios user, and would allow attackers to elevate the…
CVSS 3.0HIGH 8.1· Network · No auth · No interaction · EPSS 0.02308 · Published 2018-09-05 · No fix listed CWE-732
Priority HIGH 67
The test connection functionality in the NetAudit section of Opsview Monitor before 5.3.1 and 5.4.x before 5.4.2 is vulnerable to command injection due to improper sanitization of the rancid_password parameter.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.32692 · Published 2018-09-05 · No fix listed CWE-78
Priority LOW 31
Open redirect vulnerability in Opsview Monitor Pro (Prior to 5.1.0.162300841, prior to 5.0.2.27475, prior to 4.6.4.162391051, and 4.5.x without a certain 2016 security patch) allows remote attackers to redirect users to…
CVSS 3.0MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.02178 · Published 2017-05-03 · No fix listed CWE-601
Priority MEDIUM 49
In Opsview Monitor Pro (Prior to 5.1.0.162300841, prior to 5.0.2.27475, prior to 4.6.4.162391051, and 4.5.x without a certain 2016 security patch), an unauthenticated Directory Traversal vulnerability can be exploited by…
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.16109 · Published 2017-05-03 · No fix listed CWE-22
Priority LOW 28
Opsview before 2015-11-06 has XSS via SNMP.
CVSS 3.0MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00652 · Published 2017-04-10 · No fix listed CWE-79
Priority LOW 23
Multiple cross-site scripting (XSS) vulnerabilities in Opsview 4.6.2 and earlier allow remote attackers to inject arbitrary web script or HTML via a (1) crafted check plugin, the (2) description in a host profile, or the…
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.01534 · Published 2015-06-18 · No fix listed CWE-79
Priority LOW 31
Cross-site request forgery (CSRF) vulnerability in Opsview before 4.4.2 allows remote attackers to hijack the authentication of unspecified victims via unknown vectors.
CVSS 2.0MEDIUM 6.8· Network · No auth · Interaction — · EPSS 0.0057 · Published 2014-01-02 · No fix listed CWE-352
Priority LOW 28
Open redirect vulnerability in Opsview before 4.4.2 allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via unspecified vectors.
CVSS 2.0MEDIUM 5.8· Network · No auth · Interaction — · EPSS 0.01168 · Published 2014-01-02 · No fix listed CWE-20
Priority LOW 22
Cross-site scripting (XSS) vulnerability in Opsview before 4.4.2 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.01148 · Published 2014-01-02 · No fix listed CWE-79
Priority LOW 22
Multiple cross-site scripting (XSS) vulnerabilities in Opsview before 4.4.1 allow remote attackers to inject arbitrary web script or HTML via the (1) id parameter to admin/auditlog/, (2) PATH_INFO to info/host/ or (3) vi…
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.0096 · Published 2013-11-05 · No fix listed CWE-79
Priority LOW 38
SQL injection vulnerability in status/service/acknowledge in Opsview before 4.4.1 allows remote attackers to execute arbitrary SQL commands via the service_selection parameter.
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.02561 · Published 2013-11-05 · No fix listed CWE-89