Priority HIGH 70
TheHive through 4.1.24 contains an unauthenticated information disclosure vulnerability that allows unauthenticated attackers to retrieve sensitive configuration data by sending a GET request to the /api/status endpoint,…
CVSS 4.0MEDIUM 6.9· Network · No auth · No interaction · EPSS 0.00449 · Published 2026-07-17 · No fix listed CWE-306
Priority LOW 30
A Broken Access Control vulnerability in StrangeBee TheHive 5.2.0 before 5.2.16, 5.3.0 before 5.3.11, and 5.4.0 before 5.4.10 allows remote, authenticated, and unprivileged users to retrieve alerts, cases, logs, observab…
CVSS 4.0MEDIUM 6.8· Network · Low privileges · User interaction · EPSS 0.0033 · Published 2025-05-23 · Fixed in 5.2.16, 5.3.11 +1 CWE-266
Priority LOW 26
A Cross-Site Request Forgery (CSRF) vulnerability in StrangeBee TheHive 5.2.0 before 5.2.16, 5.3.0 before 5.3.11, 5.4.0 before 5.4.10, and 5.5.0 before 5.5.1 allows a remote attacker to trigger requests on their victim's…
CVSS 4.0MEDIUM 5.9· Network · No auth · User interaction · EPSS 0.00275 · Published 2025-05-23 · Fixed in 5.2.16, 5.3.11 +2 CWE-352
Priority LOW 22
A Server-Side Request Forgery (SSRF) vulnerability in StrangeBee TheHive 5.2.0 before 5.2.16, 5.3.0 before 5.3.11, 5.4.0 before 5.4.10, and 5.5.0 before 5.5.1 allows remote authenticated attackers with admin permissions…
CVSS 4.0MEDIUM 4.6· Network · High privileges · User interaction · EPSS 0.00435 · Published 2025-05-23 · Fixed in 5.2.16, 5.3.11 +2 CWE-918
Priority LOW 37
An e-mail flooding vulnerability in StrangeBee TheHive 5.2.0 before 5.2.16, 5.3.0 before 5.3.11, 5.4.0 before 5.4.10, and 5.5.0 before 5.5.1 allows unauthenticated remote attackers to use the password reset feature witho…
CVSS 4.0MEDIUM 6.9· Network · No auth · No interaction · EPSS 0.00533 · Published 2025-05-23 · Fixed in 5.2.16, 5.3.11 +2 CWE-770
Priority LOW 24
StrangeBee TheHive 5.2.0 to 5.2.8 is vulnerable to Cross Site Scripting (XSS) in the case reporting functionality.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00289 · Published 2024-01-19 · No fix listed CWE-79
Priority LOW 24
StrangeBee TheHive 5.1.0 to 5.1.9 and 5.2.0 to 5.2.8 is vulnerable to Cross Site Scripting (XSS) in the case attachment functionality which enables an attacker to upload a malicious HTML file with Javascript code that wi…
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00289 · Published 2024-01-19 · No fix listed CWE-79
Priority MEDIUM 45
An issue in StrangeBee TheHive v.5.0.8, v.4.1.21 and Cortex v.3.1.6 allows a remote attacker to gain privileges via Active Directory authentication mechanism.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00926 · Published 2023-09-11 · No fix listed CWE-287
Priority MEDIUM 42
An improper authorization check in the User API in TheHive before 2.13.4 and 3.x before 3.3.1 allows users with read-only or read/write access to escalate their privileges to the administrator's privileges.
CVSS 3.0HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.01864 · Published 2019-06-02 · No fix listed CWE-264