Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
1 selected

31 records

Priority LOW 28

The Paid Memberships Pro – Content Restriction, User Registration, & Paid Subscriptions plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Readonly User Field via [pmpro_member_profile_edit] Shortcode…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00261 Published 2026-07-28 No fix listed CWE-79
Priority LOW 28

The Memberlite Shortcodes plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugins's 'row' shortcode in all versions up to, and including, 1.4 due to insufficient input sanitization and output es…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00279 Published 2025-09-17 No fix listed CWE-80
Priority LOW 29

The Memberlite Shortcodes plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's memberlite_accordion shortcode in all versions up to, and including, 1.3.9 due to insufficient input sanitizati…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00472 Published 2024-11-23 No fix listed CWE-79
Priority MEDIUM 49

Authorization Bypass Through User-Controlled Key vulnerability in Paid Memberships Pro allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects Paid Memberships Pro: from n/a through 3.0.4.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.0067 Published 2024-11-01 No fix listed CWE-639
Priority MEDIUM 62

The pmpro-member-directory WordPress plugin before 1.2.6 does not prevent users with at least the contributor role from leaking other users' sensitive information, including password hashes via an SQLi vector.

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.00523 Published 2024-07-30 Fixed in 1.2.6 CWE-202
Priority LOW 24

The Paid Memberships Pro – Content Restriction, User Registration, & Paid Subscriptions plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.0.1.

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.00297 Published 2024-05-02 No fix listed CWE-352
Priority LOW 22

The Paid Memberships Pro – Content Restriction, User Registration, & Paid Subscriptions plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.12.10.

CVSS 3.1MEDIUM 4.3 Network No auth User interaction EPSS 0.00904 Published 2024-04-09 No fix listed CWE-352
Priority LOW 31

The Paid Memberships Pro – Content Restriction, User Registration, & Paid Subscriptions plugin for WordPress is vulnerable to unauthorized modification of membership levels created by the plugin due to an incorrectly imp…

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.00508 Published 2024-01-11 No fix listed CWE-862
Priority HIGH 70

The Paid Memberships Pro plugin for WordPress is vulnerable to arbitrary file uploads due to insufficient file type validation in the 'pmpro_paypalexpress_session_vars_for_user_fields' function in versions up to, and inc…

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.51254 Published 2023-11-18 No fix listed CWE-434
Priority MEDIUM 58

The Memberlite Shortcodes WordPress plugin before 1.3.9 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to…

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00531 Published 2023-10-31 Fixed in 1.3.9 CWE-79
Priority HIGH 75

The Paid Memberships Pro WordPress plugin before 2.9.12 does not prevent subscribers from rendering shortcodes that concatenate attributes directly into an SQL query.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.60452 Published 2023-03-20 Fixed in 2.9.12 CWE-89
Priority MEDIUM 63

The Paid Memberships Pro WordPress plugin before 2.9.9 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to p…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.65006 Published 2023-02-13 Fixed in 2.9.9 CWE-79
Priority CRITICAL 92

The Paid Memberships Pro WordPress Plugin, version < 2.9.8, is affected by an unauthenticated SQL injection vulnerability in the 'code' parameter of the '/pmpro/v1/order' REST route.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.9246 Published 2023-01-20 Fixed in 2.9.8 CWE-89
Load more