Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
1 selected

11 records

Priority LOW 36

Timescale pgvectorscale before 0.9.1 contains a type confusion vulnerability that allows low-privileged database users to corrupt memory by shadowing pgvector's vector type or operators.

CVSS 4.0HIGH 7.7 Network Low privileges No interaction EPSS 0.00498 Published 2026-10-26 Fixed in 0.9.1 CWE-843
Priority LOW 32

TimescaleDB through 2.29.1, fixed in commit 517c13e, contains an out-of-bounds read vulnerability in the Gorilla compression reverse row iterator that allows authenticated attackers to cause a denial of service by storin…

CVSS 4.0HIGH 7.1 Network Low privileges No interaction EPSS 0.00513 Published 2026-08-06 Fixed CWE-125
Priority MEDIUM 41

pgai is a Python library that transforms PostgreSQL into a retrieval engine for RAG and Agentic applications.

CVSS 3.1CRITICAL 9.1 Network No auth No interaction EPSS 0.00402 Published 2025-06-19 Fixed in 8eb356729c33560ce54b88b9a956960ad1e3ede8 CWE-200
Priority MEDIUM 41

TimescaleDB, an open-source time-series SQL database, has a privilege escalation vulnerability in versions 2.8.0 through 2.9.2.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.00775 Published 2023-02-14 Fixed in 2.9.3 CWE-284