Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
1 selected

21 records

Priority LOW 29

ViewVC, a browser interface for CVS and Subversion version control repositories, as a cross-site scripting vulnerability that affects versions prior to 1.2.2 and 1.1.29.

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00754 Published 2023-01-03 Fixed in 1.1.29, 1.2.2 CWE-79
Priority LOW 20

ViewVC before versions 1.1.28 and 1.2.1 has a XSS vulnerability in CVS show_subdir_lastmod support.

CVSS 3.1LOW 3.5 Network High privileges User interaction EPSS 0.01363 Published 2020-04-03 Fixed in 1.1.28, 1.2.1 CWE-80
Priority LOW 26

Cross-site scripting (XSS) vulnerability in the "extra" details in the DiffSource._get_row function in lib/viewvc.py in ViewVC 1.0.x before 1.0.13 and 1.1.x before 1.1.16 allows remote authenticated users with repository…

CVSS 2.0MEDIUM 4.3 Network No auth Interaction — EPSS 0.03085 Published 2012-11-19 No fix listed CWE-79
Priority LOW 27

The SVN revision view (lib/vclib/svn/svn_repos.py) in ViewVC before 1.1.15 does not properly handle log messages when a readable path is copied from an unreadable path, which allows remote attackers to obtain sensitive i…

CVSS 2.0MEDIUM 5.0 Network No auth Interaction — EPSS 0.01884 Published 2012-07-22 No fix listed CWE-200
Priority LOW 28

ViewVC before 1.1.11 allows remote attackers to bypass the cvsdb row_limit configuration setting, and consequently conduct resource-consumption attacks, via the limit parameter, as demonstrated by a "query revision histo…

CVSS 2.0MEDIUM 5.0 Network No auth Interaction — EPSS 0.02644 Published 2011-05-23 No fix listed CWE-399
Priority LOW 18

Cross-site scripting (XSS) vulnerability in ViewVC 1.1 before 1.1.5 and 1.0 before 1.0.11, when the regular expression search functionality is enabled, allows remote attackers to inject arbitrary web script or HTML via v…

CVSS 2.0LOW 2.6 Network No auth Interaction — EPSS 0.02334 Published 2010-03-31 No fix listed CWE-79
Priority LOW 33

ViewVC 1.0.2 and earlier does not specify a charset in its HTTP headers or HTML documents, which allows remote attackers to conduct cross-site scripting (XSS) attacks that inject arbitrary UTF-7 encoded JavaScript code v…

CVSS 2.0MEDIUM 6.8 Network No auth Interaction — EPSS 0.01528 Published 2006-10-21 No fix listed