Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
1 selected

34 records

Priority LOW 38

The WP Fastest Cache – WordPress Cache Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via HTTP Host Header in all versions up to, and including, 1.5.0 due to insufficient input sanitization and…

CVSS 3.1HIGH 7.2 Network No auth No interaction EPSS 0.00419 Published 2026-08-26 No fix listed CWE-79
Priority MEDIUM 50

The WP Fastest Cache Premium plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 1.7.4 via the 'get_server_time_ajax_request' AJAX action.

CVSS 3.1LOW 3.5 Network Low privileges No interaction EPSS 0.0029 Published 2025-12-12 No fix listed CWE-862
Priority LOW 20

The WP Fastest Cache plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the wpfc_db_fix_callback() function in all versions up to, and including, 1.4.0.

CVSS 3.1MEDIUM 4.3 Network Low privileges No interaction EPSS 0.00234 Published 2025-11-27 No fix listed CWE-862
Priority HIGH 70

The WP Fastest Cache plugin for WordPress is vulnerable to unauthorized arbitrary file deletion in versions up to, and including, 0.9.0.2 due to a lack of capability checking and insufficient path validation.

CVSS 3.1HIGH 8.1 Network Low privileges No interaction EPSS 0.01491 Published 2024-10-16 Fixed in 0.9.0.3 CWE-352
Priority MEDIUM 60

The WP Fastest Cache WordPress plugin before 0.9.5 is lacking a CSRF check in its wpfc_save_cdn_integration AJAX action, and does not sanitise and escape some the options available via the action, which could allow attac…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00252 Published 2024-01-16 Fixed in 0.9.5 CWE-352
Priority HIGH 73

The WP Fastest Cache WordPress plugin before 0.9.5 does not escape user input in the set_urls_with_terms method before using it in a SQL statement, leading to an SQL injection exploitable by low privilege users such as s…

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.01178 Published 2024-01-16 Fixed in 0.9.5 CWE-89
Priority HIGH 71

The WP Fastest Cache WordPress plugin before 1.2.2 does not properly sanitise and escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by unauthenticated users.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.73708 Published 2023-12-04 Fixed in 1.2.2 CWE-89
Priority LOW 21

The WP Fastest Cache plugin for WordPress is vulnerable to unauthorized cache deletion in versions up to, and including, 1.1.2 due to a missing capability check in the deleteCacheToolbar function .

CVSS 3.1MEDIUM 4.3 Network Low privileges No interaction EPSS 0.00534 Published 2023-06-09 No fix listed CWE-862
Priority HIGH 73

The WP Fastest Cache WordPress plugin before 1.1.5 does not have CSRF check in an AJAX action, and does not validate user input before using it in the wp_remote_get() function, leading to a Blind SSRF issue

CVSS 3.1HIGH 8.8 Network No auth User interaction EPSS 0.08466 Published 2023-05-30 Fixed in 1.1.5
Priority LOW 20

The WP Fastest Cache plugin for WordPress is vulnerable to unauthorized data modification due to a missing capability check on the wpfc_preload_single_callback function in versions up to, and including, 1.1.2.

CVSS 3.1MEDIUM 4.3 Network Low privileges No interaction EPSS 0.00386 Published 2023-04-06 No fix listed CWE-862
Priority LOW 20

The WP Fastest Cache plugin for WordPress is vulnerable to unauthorized data loss due to a missing capability check on the deleteCssAndJsCacheToolbar function in versions up to, and including, 1.1.2.

CVSS 3.1MEDIUM 4.3 Network Low privileges No interaction EPSS 0.00386 Published 2023-04-06 No fix listed CWE-862
Load more