Read the docs
Red Hat Security Advisory

RHSA-2012:1542

CloudForms Commons 1.1 security update

Released 2012-12-04 · Red Hat rating Moderate · View on Red Hat →

Fixed in

Fixes 16 records

Priority LOW 38

The Active Record component in Ruby on Rails before 3.0.14, 3.1.x before 3.1.6, and 3.2.x before 3.2.6 does not properly implement the passing of request data to a where method in an ActiveRecord class, which allows remo…

CVSS 2.0HIGH 7.5 Network No auth Interaction — EPSS 0.02947 Published 2012-06-22 Fixed in 3.0.14, 3.1.6 +2 CWE-89
Priority LOW 36

actionpack/lib/action_dispatch/http/request.rb in Ruby on Rails before 3.0.13, 3.1.x before 3.1.5, and 3.2.x before 3.2.4 does not properly consider differences in parameter handling between the Active Record component a…

CVSS 2.0MEDIUM 6.4 Network No auth Interaction — EPSS 0.04549 Published 2012-06-22 Fixed in 3.0.13, 3.1.5 +2 CWE-264
Priority LOW 32

Puppet 2.6.x before 2.6.15 and 2.7.x before 2.7.13, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x, and 2.5.x before 2.5.1 allows remote authenticated users with agent SSL keys and file-creation permissions on t…

CVSS 2.0MEDIUM 6.0 Network Low privileges Interaction — EPSS 0.02602 Published 2012-05-29 Partial fix · 2.6.15, 2.7.13 CWE-78
Priority LOW 30

The Active Record component in Ruby on Rails 3.0.x before 3.0.13, 3.1.x before 3.1.5, and 3.2.x before 3.2.4 does not properly implement the passing of request data to a where method in an ActiveRecord class, which allow…

CVSS 2.0MEDIUM 5.0 Network No auth Interaction — EPSS 0.04042 Published 2012-06-22 Fixed in 3.0.13, 3.1.5 +1 CWE-89
TI-2012-02953 CVE-2012-3424 · GHSA-92w9-2pqw-rhjj

The decode_credentials method in…

Priority LOW 27

The decode_credentials method in actionpack/lib/action_controller/metal/http_authentication.rb in Ruby on Rails 3.x before 3.0.16, 3.1.x before 3.1.7, and 3.2.x before 3.2.7 converts Digest Authentication strings to symb…

CVSS 2.0MEDIUM 5.0 Network No auth Interaction — EPSS 0.01889 Published 2012-08-08 Fixed in 3.0.16, 3.1.7 +2 CWE-287
Priority LOW 27

actionpack/lib/action_dispatch/http/request.rb in Ruby on Rails before 3.0.14, 3.1.x before 3.1.6, and 3.2.x before 3.2.6 does not properly consider differences in parameter handling between the Active Record component a…

CVSS 2.0MEDIUM 4.3 Network No auth Interaction — EPSS 0.03887 Published 2012-06-22 Fixed in 3.0.14, 3.1.6 +1 CWE-264
Priority LOW 25

lib/puppet/ssl/certificate_authority.rb in Puppet before 2.6.17 and 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, does not properly restrict the characters in the Common Name field of a Certificate Signing Req…

CVSS 2.0MEDIUM 4.3 Network No auth Interaction — EPSS 0.02453 Published 2012-08-06 Partial fix · 2.6.17, 2.7.18 CWE-264
Priority LOW 25

Cross-site scripting (XSS) vulnerability in activesupport/lib/active_support/core_ext/string/output_safety.rb in Ruby on Rails before 3.0.17, 3.1.x before 3.1.8, and 3.2.x before 3.2.8 might allow remote attackers to inj…

CVSS 2.0MEDIUM 4.3 Network No auth Interaction — EPSS 0.02568 Published 2012-08-10 Fixed in 3.0.17, 3.1.8 +2 CWE-79
Priority LOW 24

Cross-site scripting (XSS) vulnerability in actionpack/lib/action_view/helpers/sanitize_helper.rb in the strip_tags helper in Ruby on Rails before 3.0.17, 3.1.x before 3.1.8, and 3.2.x before 3.2.8 allows remote attacker…

CVSS 2.0MEDIUM 4.3 Network No auth Interaction — EPSS 0.01994 Published 2012-08-10 Fixed in 3.0.17, 3.1.8 +2 CWE-79
Priority LOW 23

Puppet before 2.6.17 and 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, allows remote authenticated users to read arbitrary files on the puppet master server by leveraging an arbitrary user's certificate and pr…

CVSS 2.0MEDIUM 4.0 Network Low privileges Interaction — EPSS 0.01914 Published 2012-08-06 Partial fix CWE-200
Priority LOW 23

Cross-site scripting (XSS) vulnerability in actionpack/lib/action_view/helpers/form_tag_helper.rb in Ruby on Rails 3.x before 3.0.17, 3.1.x before 3.1.8, and 3.2.x before 3.2.8 allows remote attackers to inject arbitrary…

CVSS 2.0MEDIUM 4.3 Network No auth Interaction — EPSS 0.01306 Published 2012-08-10 Fixed in 3.0.17, 3.1.8 +1 CWE-79
Priority LOW 22

Unspecified vulnerability in Puppet 2.6.x before 2.6.15 and 2.7.x before 2.7.13, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x, and 2.5.x before 2.5.1 allows remote authenticated users with agent SSL keys to (1…

CVSS 2.0LOW 3.5 Network Low privileges Interaction — EPSS 0.02524 Published 2012-05-29 Partial fix · 2.6.15, 2.7.13 CWE-400
Priority LOW 21

Directory traversal vulnerability in lib/puppet/reports/store.rb in Puppet before 2.6.17 and 2.7.x before 2.7.18, and Puppet Enterprise before 2.5.2, when Delete is enabled in auth.conf, allows remote authenticated users…

CVSS 2.0LOW 3.5 Network Low privileges Interaction — EPSS 0.01882 Published 2012-08-06 Partial fix · 2.6.17, 2.7.18 CWE-22
Priority LOW 14

Puppet 2.6.x before 2.6.15 and 2.7.x before 2.7.13, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x, and 2.5.x before 2.5.1 allows remote authenticated users with an authorized SSL key and certain permissions on…

CVSS 2.0LOW 2.1 Network Low privileges Interaction — EPSS 0.01453 Published 2012-05-29 Partial fix CWE-264