Read the docs
TI-2012-01761 Aliases CVE-2012-1987GHSA-v58w-6xc2-w799

Unspecified vulnerability in Puppet 2.6.x before 2.6.15 and 2.7.x before 2.7.13, and…

Priority LOW 22CWE-400Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Medium
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · Partial
Fix status
Partial Red Hat: 2 fixed, 1 without a fix

Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-400.

Summary

Unspecified vulnerability in Puppet 2.6.x before 2.6.15 and 2.7.x before 2.7.13, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x, and 2.5.x before 2.5.1 allows remote authenticated users with agent SSL keys to (1) cause a denial of service (memory consumption) via a REST request to a stream that triggers a thread block, as demonstrated using CVE-2012-1986 and /dev/random; or (2) cause a denial of service (filesystem consumption) via crafted REST requests that use "a marshaled form of a Puppet::FileBucket::File object" to write to arbitrary file locations.

Why it matters now

EPSS 0.02524 84th percentileScored 2026-11-07
Fix Partial puppet (RubyGems): 2.6.15, 2.7.13Red Hat: 1 advisoryRed Hat: 2 fixed, 1 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—puppet (RubyGems)2.6.0 to before 2.6.152.6.15Patch availableGHSA-v58w-6xc2-w799
—puppet (RubyGems)2.7.0 to before 2.7.132.7.13Patch availableGHSA-v58w-6xc2-w799
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • puppet (RubyGems) Vendor— Affected 2.6.0 to before 2.6.15 Fixed in 2.6.15 Patch available GHSA-v58w-6xc2-w799
  • puppet (RubyGems) Vendor— Affected 2.7.0 to before 2.7.13 Fixed in 2.7.13 Patch available GHSA-v58w-6xc2-w799

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:puppet:puppet:*:*:*:*:*:*:*:*2.6.0 to before 2.6.15; 2.7.0 to before 2.7.13VulnerablePuppet
cpe:2.3:a:puppet:puppet_enterprise:*:*:*:*:*:*:*:*1.0 to before 2.5.1VulnerablePuppet
  • cpe:2.3:a:puppet:puppet:*:*:*:*:*:*:*:* Versions 2.6.0 to before 2.6.15; 2.7.0 to before 2.7.13 Vulnerable ·Puppet
  • cpe:2.3:a:puppet:puppet_enterprise:*:*:*:*:*:*:*:* Versions 1.0 to before 2.5.1 Vulnerable ·Puppet

Remediation

  • Fix · GHSA-v58w-6xc2-w799 puppet (RubyGems) Fixed in 2.6.15 Advisory →
  • Fix · GHSA-v58w-6xc2-w799 puppet (RubyGems) Fixed in 2.7.13 Advisory →

Red Hat 1 advisory

  • RHSA-2012:1542 Released 2012-12-04 · Red Hat rating Moderate
    CloudForms Commons 1.1 security update
    • CloudForms Cloud Engine for RHEL 6 Server converge-ui-devel-1.0.4-1.el6cf, puppet-2.6.17-2.el6cf, puppet-server-2.6.17-2.el6cf +13
    • CloudForms System Engine for RHEL 6 Server converge-ui-devel-1.0.4-1.el6cf, puppet-2.6.17-2.el6cf, puppet-server-2.6.17-2.el6cf +13

Vendor assessments

Red Hat

Red Hat rating: Low. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise MRG 1AffectedNo fix planned: Will not fix
CloudForms Cloud Engine for RHEL 6 ServerFixed RHSA-2012:1542
CloudForms System Engine for RHEL 6 ServerFixed RHSA-2012:1542

Timeline

  1. 2026-10-02 Threatist record created from CVE-2012-1987
  2. 2026-10-03 Alias added: GHSA-v58w-6xc2-w799

References

  • TI-2016-02327 Puppet Server before 2.3.2 and Ruby puppetmaster in Puppet 4.x before 4.4.2 and in Puppet… CVSS 3.1CRITICAL 9.8
  • TI-2013-01442 The (1) template and (2) inline_template functions in the master server in Puppet before… CVSS 2.0HIGH 9.0
  • TI-2021-08594 SQL injection in Puppet DB CVSS 3.1HIGH 8.8
  • TI-2017-01576 Deserialization of untrusted data in Puppet server CVSS 3.0HIGH 8.2
  • TI-2018-04793 Untrusted search path in Puppet Enterprise and Puppet Agent CVSS 3.0HIGH 8.8
  • TI-2013-01456 Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, when running Ruby 1.9.3 or later… CVSS 2.0HIGH 7.5
See all 41 →

Sources