Red Hat Security AdvisoryRHSA-2017:3485
rh-ruby24-ruby security, bug fix, and enhancement update
Released 2017-12-19 · Red Hat rating Moderate · View on Red Hat →
Fixed in
- Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 6) rh-ruby24-ruby-2.4.2-86.el6, rh-ruby24-ruby-devel-2.4.2-86.el6, rh-ruby24-ruby-doc-2.4.2-86.el6 +17
- Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7) rh-ruby24-ruby-2.4.2-86.el7, rh-ruby24-ruby-devel-2.4.2-86.el7, rh-ruby24-ruby-doc-2.4.2-86.el7 +17
- Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 6.7) rh-ruby24-ruby-2.4.2-86.el6, rh-ruby24-ruby-devel-2.4.2-86.el6, rh-ruby24-ruby-doc-2.4.2-86.el6 +17
- Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.3) rh-ruby24-ruby-2.4.2-86.el7, rh-ruby24-ruby-devel-2.4.2-86.el7, rh-ruby24-ruby-doc-2.4.2-86.el7 +17
- Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.4) rh-ruby24-ruby-2.4.2-86.el7, rh-ruby24-ruby-devel-2.4.2-86.el7, rh-ruby24-ruby-doc-2.4.2-86.el7 +17
- Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 6) rh-ruby24-ruby-2.4.2-86.el6, rh-ruby24-ruby-devel-2.4.2-86.el6, rh-ruby24-ruby-doc-2.4.2-86.el6 +17
- Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7) rh-ruby24-ruby-2.4.2-86.el7, rh-ruby24-ruby-devel-2.4.2-86.el7, rh-ruby24-ruby-doc-2.4.2-86.el7 +17
Fixes 8 records
Priority MEDIUM 58
RubyGems versions between 2.0.0 and 2.6.13 are vulnerable to a possible remote code execution vulnerability.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.15853 · Published 2017-10-11 · Fixed in 2.6.14 CWE-502
Priority MEDIUM 56
RubyGems version 2.6.12 and earlier fails to validate specification names, allowing a maliciously crafted gem to potentially overwrite any file on the filesystem.
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.29442 · Published 2017-08-31 · Partial fix · 2.6.13 CWE-22
Priority MEDIUM 55
The Basic authentication code in WEBrick library in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows remote attackers to inject terminal emulator escape sequences into its log and possibly execute ar…
CVSS 3.0HIGH 8.8· Network · No auth · User interaction · EPSS 0.16412 · Published 2017-09-19 · Partial fix · 1.4.0 CWE-287
Priority MEDIUM 55
RubyGems version 2.6.12 and earlier is vulnerable to maliciously crafted gem specifications that include terminal escape characters.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.11102 · Published 2017-08-31 · Partial fix · 2.6.13 CWE-150
Priority MEDIUM 54
Ruby through 2.2.7, 2.3.x through 2.3.4, and 2.4.x through 2.4.1 can expose arbitrary memory during a JSON.generate call.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.09445 · Published 2017-08-31 · Partial fix CWE-119
Priority MEDIUM 51
Ruby before 2.4.2, 2.3.5, and 2.2.8 is vulnerable to a malicious format string which contains a precious specifier (*) with a huge minus value.
CVSS 3.0CRITICAL 9.1· Network · No auth · No interaction · EPSS 0.09718 · Published 2017-09-15 · Partial fix CWE-134
Priority MEDIUM 44
RubyGems version 2.6.12 and earlier is vulnerable to maliciously crafted gem specifications to cause a denial of service attack against RubyGems clients who have issued a `query` command.
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.08491 · Published 2017-08-31 · Partial fix · 2.6.13 CWE-20
Priority MEDIUM 43
RubyGems version 2.6.12 and earlier is vulnerable to a DNS hijacking vulnerability that allows a MITM attacker to force the RubyGems client to download and install gems from a server that the attacker controls.
CVSS 3.0HIGH 8.1· Network · No auth · No interaction · EPSS 0.0475 · Published 2017-08-31 · Partial fix · 2.6.13 CWE-350