Red Hat Security AdvisoryRHSA-2018:0336
Satellite 6.3 security, bug fix, and enhancement update
Released 2018-02-21 · Red Hat rating Important · View on Red Hat →
Fixes 22 records
Priority MEDIUM 45
The Zone::New function in zone.cc in Google V8 before 5.0.71.47, as used in Google Chrome before 50.0.2661.102, does not properly determine when to expand certain memory allocations, which allows remote attackers to caus…
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.04262 · Published 2016-05-14 · Partial fix CWE-119
Priority MEDIUM 41
Versions of Puppet prior to 4.10.1 will deserialize data off the wire (from the agent to the server, in this case) with a attacker-specified format.
CVSS 3.0HIGH 8.2· Network · Low privileges · No interaction · EPSS 0.02762 · Published 2017-07-05 · Partial fix CWE-502
Priority MEDIUM 40
A flaw was found in foreman before version 1.15 in the logging of adding and registering images.
CVSS 3.0HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.01162 · Published 2018-06-21 · Partial fix CWE-312
Priority MEDIUM 40
foreman-debug before version 1.15.0 is vulnerable to a flaw in foreman-debug's logging.
CVSS 3.0HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.00968 · Published 2018-04-16 · Fixed CWE-522
Priority LOW 39
The Safemode gem before 1.2.4 for Ruby, when initialized with a delegate object that is a Rails controller, allows context-dependent attackers to obtain sensitive information via the inspect method.
CVSS 3.0HIGH 8.1· Network · No auth · No interaction · EPSS 0.02131 · Published 2016-05-20 · Partial fix · 1.2.4 CWE-200
Priority LOW 37
Pulp before 2.8.5 uses bash's $RANDOM in an unsafe way to generate passwords.
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.0198 · Published 2017-06-13 · Fixed CWE-255
Priority LOW 36
Hammer CLI, a CLI utility for Foreman, before version 0.10.0, did not explicitly set the verify_ssl flag for apipie-bindings that disable it by default.
CVSS 3.1HIGH 8.1· Network · No auth · No interaction · EPSS 0.00692 · Published 2018-03-12 · Partial fix · 0.10.0 CWE-345
Priority LOW 35
A Denial of Service vulnerability was found in Apache Qpid Dispatch Router versions 0.7.0 and 0.8.0.
CVSS 3.1MEDIUM 6.5· Network · Low privileges · No interaction · EPSS 0.03219 · Published 2018-02-13 · Partial fix CWE-20
Priority LOW 34
It was found that foreman, versions 1.x.x before 1.15.6, in Satellite 6 did not properly enforce access controls on certain resources.
CVSS 3.1HIGH 7.4· Network · Low privileges · No interaction · EPSS 0.00749 · Published 2019-08-01 · Fixed in 1.15.6 CWE-284
Priority LOW 33
A flaw was found in foreman 1.5.1.
CVSS 3.0MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.02396 · Published 2018-07-31 · Fixed CWE-79
Priority LOW 32
A flaw was found in katello-debug before 3.4.0 where certain scripts and log files used insecure temporary files.
CVSS 3.0HIGH 7.3· Local · Low privileges · User interaction · EPSS 0.00403 · Published 2018-07-27 · Fixed CWE-377
Priority LOW 31
Cross-site scripting (XSS) vulnerability in app/helpers/form_helper.rb in Foreman before 1.12.2, as used by Remote Execution and possibly other plugins, allows remote attackers to inject arbitrary web script or HTML via…
CVSS 3.0MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.0196 · Published 2016-08-19 · Partial fix CWE-79
Priority LOW 31
discovery-debug in Foreman before 6.2 when the ssh service has been enabled on discovered nodes displays the root password in plaintext in the system journal when used to log in, which allows local users with access to t…
CVSS 3.0HIGH 7.0· Local · Low privileges · No interaction · EPSS 0.00309 · Published 2017-07-14 · Partial fix CWE-255
Priority LOW 30
It was found that foreman before 1.13.0 is vulnerable to a stored XSS via an organization or location name.
CVSS 3.0MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.0116 · Published 2018-08-01 · Partial fix CWE-79
Priority LOW 29
A vulnerability was found in foreman 1.14.0.
CVSS 3.0MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.01094 · Published 2018-08-01 · Partial fix CWE-79
Priority LOW 26
Foreman before 1.11.4 and 1.12.x before 1.12.1 does not properly restrict access to preview provisioning templates, which allows remote authenticated users with permission to view some hosts to obtain sensitive host conf…
CVSS 3.0MEDIUM 5.3· Network · Low privileges · No interaction · EPSS 0.01083 · Published 2016-08-19 · Partial fix CWE-200
Priority LOW 25
The (1) Organization and (2) Locations APIs in Foreman before 1.11.3 and 1.12.x before 1.12.0-RC1 allow remote authenticated users with unlimited filters to bypass organization and location restrictions and read or modif…
CVSS 3.0MEDIUM 5.0· Network · Low privileges · No interaction · EPSS 0.00933 · Published 2016-08-19 · Partial fix CWE-254
Priority LOW 25
The pulp-qpid-ssl-cfg script in Pulp before 2.8.5 allows local users to obtain the CA key.
CVSS 3.0MEDIUM 5.5· Local · Low privileges · No interaction · EPSS 0.00352 · Published 2017-06-13 · Fixed CWE-200
Priority LOW 24
Cross-site scripting (XSS) vulnerability in the will_paginate gem before 3.0.5 for Ruby allows remote attackers to inject arbitrary web script or HTML via vectors involving generated pagination links.
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.02209 · Published 2013-12-31 · Partial fix · 3.0.5 CWE-79
Priority LOW 23
A SQL injection flaw was found in katello's errata-related API.
CVSS 3.0MEDIUM 4.3· Network · Low privileges · No interaction · EPSS 0.01428 · Published 2018-12-13 · Partial fix CWE-209
Priority LOW 23
foreman before version 1.15.0 is vulnerable to an information leak through organizations and locations feature.
CVSS 3.0MEDIUM 4.3· Network · Low privileges · No interaction · EPSS 0.0136 · Published 2018-09-10 · Partial fix CWE-285
Priority LOW 23
foreman before 1.14.0 is vulnerable to an information leak.
CVSS 3.0MEDIUM 4.3· Network · Low privileges · No interaction · EPSS 0.01366 · Published 2018-09-10 · Partial fix CWE-285