Red Hat Security AdvisoryRHSA-2018:0585
rh-ruby23-ruby security, bug fix, and enhancement update
Released 2018-03-26 · Red Hat rating Important · View on Red Hat →
Fixed in
- Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 6) rh-ruby23-ruby-2.3.6-67.el6, rh-ruby23-ruby-devel-2.3.6-67.el6, rh-ruby23-ruby-doc-2.3.6-67.el6 +16
- Red Hat Software Collections for Red Hat Enterprise Linux Server (v. 7) rh-ruby23-ruby-2.3.6-67.el7, rh-ruby23-ruby-devel-2.3.6-67.el7, rh-ruby23-ruby-doc-2.3.6-67.el7 +16
- Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 6.7) rh-ruby23-ruby-2.3.6-67.el6, rh-ruby23-ruby-devel-2.3.6-67.el6, rh-ruby23-ruby-doc-2.3.6-67.el6 +16
- Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.3) rh-ruby23-ruby-2.3.6-67.el7, rh-ruby23-ruby-devel-2.3.6-67.el7, rh-ruby23-ruby-doc-2.3.6-67.el7 +16
- Red Hat Software Collections for Red Hat Enterprise Linux Server EUS (v. 7.4) rh-ruby23-ruby-2.3.6-67.el7, rh-ruby23-ruby-devel-2.3.6-67.el7, rh-ruby23-ruby-doc-2.3.6-67.el7 +16
- Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 6) rh-ruby23-ruby-2.3.6-67.el6, rh-ruby23-ruby-devel-2.3.6-67.el6, rh-ruby23-ruby-doc-2.3.6-67.el6 +16
- Red Hat Software Collections for Red Hat Enterprise Linux Workstation (v. 7) rh-ruby23-ruby-2.3.6-67.el7, rh-ruby23-ruby-devel-2.3.6-67.el7, rh-ruby23-ruby-doc-2.3.6-67.el7 +16
Fixes 11 records
Priority HIGH 76
Ruby before 2.4.3 allows Net::FTP command injection.
CVSS 3.0HIGH 8.8· Network · No auth · User interaction · EPSS 0.73829 · Published 2017-12-15 · Partial fix CWE-78
Priority MEDIUM 58
RubyGems versions between 2.0.0 and 2.6.13 are vulnerable to a possible remote code execution vulnerability.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.15853 · Published 2017-10-11 · Fixed in 2.6.14 CWE-502
Priority MEDIUM 56
RubyGems version 2.6.12 and earlier fails to validate specification names, allowing a maliciously crafted gem to potentially overwrite any file on the filesystem.
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.29442 · Published 2017-08-31 · Partial fix · 2.6.13 CWE-22
Priority MEDIUM 55
The Basic authentication code in WEBrick library in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows remote attackers to inject terminal emulator escape sequences into its log and possibly execute ar…
CVSS 3.0HIGH 8.8· Network · No auth · User interaction · EPSS 0.16412 · Published 2017-09-19 · Partial fix · 1.4.0 CWE-287
Priority MEDIUM 55
RubyGems version 2.6.12 and earlier is vulnerable to maliciously crafted gem specifications that include terminal escape characters.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.11102 · Published 2017-08-31 · Partial fix · 2.6.13 CWE-150
Priority MEDIUM 54
Ruby through 2.2.7, 2.3.x through 2.3.4, and 2.4.x through 2.4.1 can expose arbitrary memory during a JSON.generate call.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.09445 · Published 2017-08-31 · Partial fix CWE-119
Priority MEDIUM 51
The lazy_initialize function in lib/resolv.rb in Ruby through 2.4.3 uses Kernel#open, which might allow Command Injection attacks, as demonstrated by a Resolv::Hosts::new argument beginning with a '|' character, a differ…
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.05913 · Published 2017-12-20 · Partial fix CWE-74
Priority MEDIUM 51
Ruby before 2.4.2, 2.3.5, and 2.2.8 is vulnerable to a malicious format string which contains a precious specifier (*) with a huge minus value.
CVSS 3.0CRITICAL 9.1· Network · No auth · No interaction · EPSS 0.09718 · Published 2017-09-15 · Partial fix CWE-134
Priority MEDIUM 44
RubyGems version 2.6.12 and earlier is vulnerable to maliciously crafted gem specifications to cause a denial of service attack against RubyGems clients who have issued a `query` command.
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.08491 · Published 2017-08-31 · Partial fix · 2.6.13 CWE-20
Priority MEDIUM 43
The decode method in the OpenSSL::ASN1 module in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows attackers to cause a denial of service (interpreter crash) via a crafted string.
CVSS 3.0HIGH 7.5· Network · No auth · No interaction · EPSS 0.07734 · Published 2017-09-19 · Partial fix · 2.0.0 CWE-119
Priority MEDIUM 43
RubyGems version 2.6.12 and earlier is vulnerable to a DNS hijacking vulnerability that allows a MITM attacker to force the RubyGems client to download and install gems from a server that the attacker controls.
CVSS 3.0HIGH 8.1· Network · No auth · No interaction · EPSS 0.0475 · Published 2017-08-31 · Partial fix · 2.6.13 CWE-350