Read the docs
Red Hat Security Advisory

RHSA-2019:2543

Ansible security and bug fix update

Released 2019-08-21 · Red Hat rating Moderate · View on Red Hat →

Fixed in

Fixes 2 records

TI-2019-07537 CVE-2019-10217 · GHSA-p75j-wc34-527c

Information disclosure in Red Hat Ansible

Priority LOW 33

A flaw was found in ansible 2.8.0 before 2.8.4.

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.01853 Published 2019-11-25 Fixed in 2.8.4 CWE-200
Priority LOW 32

ansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x before 2.6.19, prompt passwords by expanding them from templates as they could contain special characters.

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.01503 Published 2019-11-22 Partial fix · 2.8.4, 2.7.13 +1 CWE-522