Insufficiently protected credentials in Red Hat Ansible
Priority LOW 32CWE-522Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 8 fixed, 4 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-522.
Summary
ansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x before 2.6.19, prompt passwords by expanding them from templates as they could contain special characters. Passwords should be wrapped to prevent templates trigger and exposing them.
Why it matters now
EPSS 0.01503 74th percentileScored 2026-11-07
Fix Partial ansible (PyPI): 2.8.4, 2.7.13, 2.6.19Red Hat: 6 advisoriesRed Hat: 8 fixed, 4 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Red Hat | Ansible | all 2.8.x before 2.8.4; all 2.7.x before 2.7.13; all 2.6.x before 2.6.19 | — | No fix listed | CNA |
| — | ansible (PyPI) | 2.8.0 to before 2.8.4 | 2.8.4 | Patch available | GHSA-cqmr-rcpr-cxh3 |
| — | ansible (PyPI) | 2.7.0 to before 2.7.13 | 2.7.13 | Patch available | GHSA-cqmr-rcpr-cxh3 |
| — | ansible (PyPI) | 2.6.0 to before 2.6.19 | 2.6.19 | Patch available | GHSA-cqmr-rcpr-cxh3 |
- Ansible VendorRed Hat Affected all 2.8.x before 2.8.4; all 2.7.x before 2.7.13; all 2.6.x before 2.6.19 Fixed in — No fix listed CNA
- ansible (PyPI) Vendor— Affected 2.8.0 to before 2.8.4 Fixed in 2.8.4 Patch available GHSA-cqmr-rcpr-cxh3
- ansible (PyPI) Vendor— Affected 2.7.0 to before 2.7.13 Fixed in 2.7.13 Patch available GHSA-cqmr-rcpr-cxh3
- ansible (PyPI) Vendor— Affected 2.6.0 to before 2.6.19 Fixed in 2.6.19 Patch available GHSA-cqmr-rcpr-cxh3
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:redhat:ansible:*:*:*:*:*:*:*:* | 2.6.0 to before 2.6.19; 2.7.0 to before 2.7.13; 2.8.0 to before 2.8.4 | Vulnerable | Red Hat |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:a:opensuse:backports_sle:15.0:sp1:*:*:*:*:*:* | 15.0 sp1 | Vulnerable | openSUSE |
| cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* | 15.1 | Vulnerable | openSUSE |
- cpe:2.3:a:redhat:ansible:*:*:*:*:*:*:*:* Versions 2.6.0 to before 2.6.19; 2.7.0 to before 2.7.13; 2.8.0 to before 2.8.4 Vulnerable ·Red Hat
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:a:opensuse:backports_sle:15.0:sp1:*:*:*:*:*:* Versions 15.0 sp1 Vulnerable ·openSUSE
- cpe:2.3:o:opensuse:leap:15.1:*:*:*:*:*:*:* Versions 15.1 Vulnerable ·openSUSE
Remediation
- Fix · GHSA-cqmr-rcpr-cxh3 ansible (PyPI) Fixed in 2.8.4 Advisory →
- Fix · GHSA-cqmr-rcpr-cxh3 ansible (PyPI) Fixed in 2.7.13 Advisory →
- Fix · GHSA-cqmr-rcpr-cxh3 ansible (PyPI) Fixed in 2.6.19 Advisory →
Red Hat 6 advisories
- RHSA-2019:3789 Released 2019-11-07 · Red Hat rating Moderateansible security update
- Red Hat OpenStack Platform 13.0 ansible-2.6.19-1.el7ae
- RHSA-2019:3744 Released 2019-11-06 · Red Hat rating Moderateansible security update
- Red Hat OpenStack Platform 14.0 ansible-2.6.19-1.el7ae
- RHSA-2019:2542 Released 2019-08-21 · Red Hat rating ModerateAnsible security and bug fix update
- Red Hat Ansible Engine 2.8 for RHEL 7 Server ansible-2.8.4-1.el7ae
- Red Hat Ansible Engine 2.8 for RHEL 8 ansible-2.8.4-1.el8ae
Show 3 more Red Hat advisories
- RHSA-2019:2543 Released 2019-08-21 · Red Hat rating ModerateAnsible security and bug fix update
- Red Hat Ansible Engine 2 for RHEL 7 ansible-2.8.4-1.el7ae
- Red Hat Ansible Engine 2 for RHEL 8 ansible-2.8.4-1.el8ae
- RHSA-2019:2545 Released 2019-08-21 · Red Hat rating ModerateAnsible security update
- Red Hat Ansible Engine 2.6 for RHEL 7 Server ansible-2.6.19-1.el7ae
- RHSA-2019:2544 Released 2019-08-21 · Red Hat rating ModerateAnsible security update
- Red Hat Ansible Engine 2.7 for RHEL 7 Server ansible-2.7.13-1.el7ae
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Ceph Storage 2 | Affected | No fix planned: Out of support scope |
| Red Hat Ceph Storage 3 | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 10 (Newton) | Affected | No fix planned: Will not fix |
| Red Hat Storage 3 | Affected | No fix planned: Will not fix |
| Red Hat Ansible Engine 2 for RHEL 7 | Fixed | RHSA-2019:2543 |
| Red Hat Ansible Engine 2 for RHEL 8 | Fixed | RHSA-2019:2543 |
| Red Hat Ansible Engine 2.6 for RHEL 7 Server | Fixed | RHSA-2019:2545 |
| Red Hat Ansible Engine 2.7 for RHEL 7 Server | Fixed | RHSA-2019:2544 |
| Red Hat Ansible Engine 2.8 for RHEL 7 Server | Fixed | RHSA-2019:2542 |
| Red Hat Ansible Engine 2.8 for RHEL 8 | Fixed | RHSA-2019:2542 |
| Red Hat OpenStack Platform 13.0 | Fixed | RHSA-2019:3789 |
| Red Hat OpenStack Platform 14.0 | Fixed | RHSA-2019:3744 |
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10206
- 2026-10-03 Alias added: GHSA-cqmr-rcpr-cxh3
References
Advisory 5
Other 6
- [debian-lts-announce] 20231228 [SECURITY] [DLA 3695-1] ansible security update
- https://github.com/ansible/ansible/commit/4b5aed4e5af4c7aab621662f50a289e99b8ac393
- https://github.com/ansible/ansible/commit/d39488ece44956f6a169a498b067bbef54552be1
- https://github.com/ansible/ansible/commit/d728127310b4f3a40ce8b9df3affb88ffaeea073
- https://github.com/ansible/ansible
- https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2019-145.yaml
More Red Hat Ansible vulnerabilities
- TI-2016-07808 Improper input validation in Ansible CVSS 3.1HIGH 8.1
- TI-2014-03853 Injection in Ansible CVSS 3.1CRITICAL 9.8
- TI-2014-03839 The safe_eval function in Ansible before 1.5.4 does not properly restrict the code… CVSS 3.1CRITICAL 9.8
- TI-2017-05191 Sensitive information in log files in Red Hat ansible CVSS 3.1CRITICAL 9.8
- TI-2014-04077 Multiple argument injection vulnerabilities in Ansible before 1.6.7 allow remote… CVSS 3.1CRITICAL 9.8
- TI-2014-04076 Ansible before 1.6.7 does not prevent inventory data with "{{" and "lookup" substrings… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2019-10206 · CVE Program
- CVE-2019-10206 · NVD
- FIRST EPSS
- GHSA-cqmr-rcpr-cxh3 · GitHub Advisory Database · CC BY 4.0
- CVE-2019-10206 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences