Red Hat Security AdvisoryRHSA-2021:3638
nodejs:12 security and bug fix update
Released 2021-09-22 · Red Hat rating Important · View on Red Hat →
Fixes 11 records
Priority HIGH 68
Node.js before 16.6.0, 14.17.4, and 12.22.4 is vulnerable to Remote Code Execution, XSS, Application crashes due to missing input validation of host names returned by Domain Name Servers in Node.js dns library which can…
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.21952 · Published 2021-08-16 · Partial fix · 12.22.5, 14.17.5 +1 CWE-170
Priority HIGH 68
Node.js before 16.6.0, 14.17.4, and 12.22.4 is vulnerable to a use after free attack where an attacker might be able to exploit the memory corruption, to change process behavior.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.36453 · Published 2021-10-07 · Partial fix · 12.22.4, 14.17.4 +1 CWE-416
Priority MEDIUM 51
The npm package "tar" (aka node-tar) before versions 6.1.1, 5.0.6, 4.4.14, and 3.3.2 has a arbitrary File Creation/Overwrite vulnerability due to insufficient absolute path sanitization.
CVSS 3.1HIGH 8.2· Local · No auth · User interaction · EPSS 0.15067 · Published 2021-08-03 · Partial fix · 3.2.2, 4.4.14 +2 CWE-22
Priority MEDIUM 48
Node.js before 16.6.1, 14.17.5, and 12.22.5 is vulnerable to a use after free attack where an attacker might be able to exploit the memory corruption, to change process behavior.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.13861 · Published 2021-08-16 · Partial fix · 12.22.5, 14.17.5 +1 CWE-416
Priority MEDIUM 46
The npm package "tar" (aka node-tar) before versions 6.1.2, 5.0.7, 4.4.15, and 3.2.3 has an arbitrary File Creation/Overwrite vulnerability via insufficient symlink protection.
CVSS 3.1HIGH 8.2· Local · No auth · User interaction · EPSS 0.07795 · Published 2021-08-03 · Partial fix · 3.2.3, 4.4.15 +2 CWE-22
Priority MEDIUM 44
Node.js before 16.4.1, 14.17.2, 12.22.2 is vulnerable to an out-of-bounds read when uv__idna_toascii() is used to convert strings to ASCII.
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.23132 · Published 2021-07-12 · Partial fix · 12.22.2, 14.17.2 +1 CWE-125
Priority MEDIUM 40
ssri 5.2.2-8.0.0, fixed in 8.0.1, processes SRIs using a regular expression which is vulnerable to a denial of service.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.0472 · Published 2021-03-12 · Partial fix · 6.0.2, 7.1.1 +1 CWE-400
Priority MEDIUM 40
If the Node.js https API was used incorrectly and "undefined" was in passed for the "rejectUnauthorized" parameter, no error was returned and connections to servers with an expired certificate would have been accepted.
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.1473 · Published 2021-08-16 · Partial fix · 12.22.5, 14.17.5 +1 CWE-295
Priority LOW 37
All versions of package path-parse are vulnerable to Regular Expression Denial of Service (ReDoS) via splitDeviceRe, splitTailRe, and splitPathRe regular expressions.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.02218 · Published 2021-05-04 · Partial fix · 1.0.7 CWE-400
Priority LOW 30
The package hosted-git-info before 3.0.8 are vulnerable to Regular Expression Denial of Service (ReDoS) via regular expression shortcutMatch in the fromUrl function in index.js.
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.03612 · Published 2021-03-23 · Partial fix · 3.0.8, 2.8.9 CWE-1333
Priority LOW 30
A flaw was found in c-ares library, where a missing input validation check of host names returned by DNS (Domain Name Servers) can lead to output of wrong hostnames which might potentially lead to Domain Hijacking.
CVSS 3.1MEDIUM 5.6· Network · No auth · No interaction · EPSS 0.02814 · Published 2021-11-23 · Partial fix CWE-79