Red Hat Security AdvisoryRHSA-2024:2721
bind and dhcp security update
Released 2024-05-07 · Red Hat rating Important · View on Red Hat →
Fixed in
- Red Hat Enterprise Linux AppStream EUS (v.8.8) bind-32:9.11.36-8.el8_8.4, bind-chroot-32:9.11.36-8.el8_8.4, bind-devel-32:9.11.36-8.el8_8.4 +12
- Red Hat Enterprise Linux BaseOS EUS (v.8.8) bind-32:9.11.36-8.el8_8.4, bind-export-devel-32:9.11.36-8.el8_8.4, bind-export-libs-32:9.11.36-8.el8_8.4 +6
Fixes 3 records
Priority HIGH 84
Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.9999 · Published 2024-02-14 · Fixed CWE-770
Priority HIGH 77
The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.74295 · Published 2024-02-14 · Fixed CWE-400
Priority LOW 36
The DNS message parsing code in `named` includes a section whose computational complexity is overly high.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.01387 · Published 2024-02-13 · Partial fix CWE-407