Red Hat Security AdvisoryRHSA-2024:3741
bind, bind-dyndb-ldap, and dhcp security update
Released 2024-06-10 · Red Hat rating Important · View on Red Hat →
Fixed in
- Red Hat Enterprise Linux Client (v. 7) bind-32:9.11.4-26.P2.el7_9.16, bind-export-libs-32:9.11.4-26.P2.el7_9.16, bind-libs-32:9.11.4-26.P2.el7_9.16 +7
- Red Hat Enterprise Linux Client Optional (v. 7) bind-32:9.11.4-26.P2.el7_9.16, bind-chroot-32:9.11.4-26.P2.el7_9.16, bind-devel-32:9.11.4-26.P2.el7_9.16 +11
- Red Hat Enterprise Linux ComputeNode Optional (v. 7) bind-32:9.11.4-26.P2.el7_9.16, bind-chroot-32:9.11.4-26.P2.el7_9.16, bind-devel-32:9.11.4-26.P2.el7_9.16 +11
- Red Hat Enterprise Linux Server (v. 7) bind-32:9.11.4-26.P2.el7_9.16, bind-chroot-32:9.11.4-26.P2.el7_9.16, bind-dyndb-ldap-11.1-7.el7_9.1 +17
- Red Hat Enterprise Linux Server Optional (v. 7) bind-devel-32:9.11.4-26.P2.el7_9.16, bind-devel-32:9.11.4-26.P2.el7_9.16.ppc, bind-export-devel-32:9.11.4-26.P2.el7_9.16 +9
- Red Hat Enterprise Linux Workstation (v. 7) bind-32:9.11.4-26.P2.el7_9.16, bind-chroot-32:9.11.4-26.P2.el7_9.16, bind-dyndb-ldap-11.1-7.el7_9.1 +12
- Red Hat Enterprise Linux Workstation Optional (v. 7) bind-devel-32:9.11.4-26.P2.el7_9.16, bind-export-devel-32:9.11.4-26.P2.el7_9.16, bind-lite-devel-32:9.11.4-26.P2.el7_9.16 +4
Fixes 3 records
Priority HIGH 84
Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.9999 · Published 2024-02-14 · Fixed CWE-770
Priority HIGH 77
The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.74295 · Published 2024-02-14 · Fixed CWE-400
Priority LOW 36
The DNS message parsing code in `named` includes a section whose computational complexity is overly high.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.01387 · Published 2024-02-13 · Partial fix CWE-407