Red Hat Security AdvisoryRHSA-2025:0039
bind and bind-dyndb-ldap security update
Released 2025-01-06 · Red Hat rating Important · View on Red Hat →
Fixed in
- Red Hat Enterprise Linux Server -EXTENSION(v. 6 ELS-EXTENSION) bind-32:9.8.2-0.68.rc1.el6_10.14, bind-chroot-32:9.8.2-0.68.rc1.el6_10.14, bind-dyndb-ldap-2.3-8.el6_10.1 +2
- Red Hat Enterprise Linux Server Optional -EXTENSION (v. 6 ELS -EXTENSION) bind-devel-32:9.8.2-0.68.rc1.el6_10.14, bind-sdb-32:9.8.2-0.68.rc1.el6_10.14
Fixes 4 records
Priority HIGH 84
Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote attackers to cause a denial of service (CPU consumption) via one or more DNSSEC responses, aka the "KeyTrap" issue…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.9999 · Published 2024-02-14 · Fixed CWE-770
Priority HIGH 77
The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows remote attackers to cause a denial of service (CPU consumption for SHA-1 computations) via DNSSEC responses in…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.74295 · Published 2024-02-14 · Fixed CWE-400
Priority MEDIUM 44
The code that processes control channel messages sent to `named` calls certain functions recursively during packet parsing.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.02934 · Published 2023-09-20 · Fixed CWE-1325
Priority LOW 36
The DNS message parsing code in `named` includes a section whose computational complexity is overly high.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.01387 · Published 2024-02-13 · Partial fix CWE-407