Read the docs
Red Hat Security Advisory

RHSA-2026:26319

Red Hat Update Infrastructure 5.2 security update

Released 2026-06-16 · Red Hat rating Important · View on Red Hat →

Fixed in

Fixes 34 records

Priority HIGH 72

The iconv() function in the GNU C Library versions 2.43 and earlier may crash due to an assertion failure when converting inputs from the IBM1390 or IBM1399 character sets, which may be used to remotely crash an applicat…

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00389 Published 2026-03-30 Partial fix CWE-617
Priority MEDIUM 49

A flaw in GnuTLS DTLS handshake parsing allows malformed fragments with zero length and non-zero offset, leading to an integer underflow during reassembly and resulting in an out-of-bounds read.

CVSS 3.1CRITICAL 9.1 Network No auth No interaction EPSS 0.02073 Published 2026-04-30 Partial fix · 3.8.13, 3.8.10-4.el10_2 +45 CWE-191
Priority MEDIUM 47

Issue summary: A specially crafted PKCS#7 or S/MIME signed message could trigger a use-after-free during PKCS#7 signature verification.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.04002 Published 2026-06-09 Partial fix · 4.0.1, 3.6.3 +5 CWE-416
Priority MEDIUM 47

Issue Summary: Cryptographic Message Services (CMS) processing fails to perform sufficient input validation on the cipher and tag length fields of AuthEnvelopedData containers, leading to various potential compromises.

CVSS 3.1CRITICAL 9.1 Network No auth No interaction EPSS 0.01057 Published 2026-06-09 Fixed in 4.0.1, 3.6.3 +3 CWE-354
Priority MEDIUM 41

Issue summary: Receiving a QUIC initial packet with an invalid token may trigger a NULL pointer dereference in the OpenSSL QUIC server with address validation disabled.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.01165 Published 2026-06-09 Partial fix · 4.0.1, 3.6.3 +1 CWE-476
Priority MEDIUM 41

Issue summary: Remote peer may exhaust heap memory of the QUIC server or client by flooding it with packets containing PATH_CHALLENGE frames.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.01049 Published 2026-06-09 Partial fix · 4.0.1, 3.6.3 +2 CWE-1325
TI-2026-33224 CVE-2026-45445 · GHSA-v446-xwfm-x7mr

AES-OCB IV Ignored on EVP_Cipher() Path

Priority MEDIUM 40

Issue summary: When an application drives an AES-OCB context through the public EVP_Cipher() one-shot interface, the application-supplied initialisation vector (IV) is silently discarded.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00704 Published 2026-06-09 Fixed in 4.0.1, 3.6.3 +3 CWE-325
Priority MEDIUM 40

Issue summary: When CMS password-based decryption (RFC 3211 / PWRI key unwrap) processes attacker-supplied CMS data, an attacker-chosen stream-mode KEK cipher can trigger a heap out-of-bounds read in kek_unwrap_key().

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00707 Published 2026-06-09 Partial fix · 4.0.1, 3.6.3 +5 CWE-125
Priority LOW 39

Issue summary: A signed integer overflow when sizing the destination buffer for Unicode output in ASN1_mbstring_ncopy() can lead to a heap buffer overflow.

CVSS 3.1HIGH 8.1 Network No auth No interaction EPSS 0.00804 Published 2026-06-09 Partial fix · 4.0.1, 3.6.3 +5 CWE-787
Priority LOW 39

Calling gethostbyaddr or gethostbyaddr_r with a configured nsswitch.conf that specifies the library's DNS backend in the GNU C Library version 2.34 to version 2.43 could, with a crafted response from the configured DNS s…

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00345 Published 2026-03-20 Partial fix CWE-125
Priority LOW 35

Issue summary: Parsing a crafted DER-encoded ASN.1 structure with a primitive element whose content exceeds 2 gigabytes in length may cause a heap buffer over-read on 64-bit Unix and Unix-like platforms.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.01025 Published 2026-06-09 Partial fix · 4.0.1, 3.6.3 +5 CWE-125
Priority LOW 33

Issue summary: An attacker-controlled CMP (Certificate Management Protocol) server could trigger a NULL pointer dereference in a CMP client application.

CVSS 3.1MEDIUM 5.9 Network No auth No interaction EPSS 0.00557 Published 2026-06-09 Partial fix · 4.0.1, 3.6.3 +3 CWE-476
Priority LOW 33

Issue Summary: The PKCS#12 file processing fails to perform sufficient input validation for files that use Password-Based Message Authentication Code 1 (PBMAC1) integrity mechanism allowing a certificate and private key…

CVSS 3.1HIGH 7.4 Network No auth No interaction EPSS 0.00376 Published 2026-06-09 Partial fix · 4.0.1, 3.6.3 +2 CWE-354
Priority LOW 29

Issue summary: A specially crafted password-encrypted CMS message can trigger a NULL pointer dereference during CMS decryption.

CVSS 3.1MEDIUM 5.9 Network No auth No interaction EPSS 0.0106 Published 2026-06-09 Partial fix · 4.0.1, 3.6.3 +5 CWE-476
Priority LOW 25

Issue Summary: An error in the callback used to verify the certificate provided in a Root CA key update Certificate Management Protocol (CMP) message response rendered the certificate validation ineffectual, which could…

CVSS 3.1MEDIUM 5.3 Network Low privileges No interaction EPSS 0.00544 Published 2026-06-09 Partial fix · 4.0.1, 3.6.3 +2 CWE-295
Priority LOW 24

Calling gethostbyaddr or gethostbyaddr_r with a configured nsswitch.conf that specifies the library's DNS backend in the GNU C library version 2.34 to version 2.43 could result in an invalid DNS hostname being returned t…

CVSS 3.1MEDIUM 5.4 Adjacent network No auth No interaction EPSS 0.00314 Published 2026-03-20 Partial fix CWE-20
Priority LOW 22

Issue summary: The implementations of AES-SIV (RFC 5297) and AES-GCM-SIV (RFC 8452) mishandle the authentication of AAD (Additional Authenticated Data) with an empty ciphertext allowing a forgery of such messages.

CVSS 3.1MEDIUM 4.8 Network No auth No interaction EPSS 0.00439 Published 2026-06-09 Partial fix · 4.0.1, 3.6.3 +3 CWE-325
Priority LOW 19

Issue summary: The CMS_decrypt and PKCS7_decrypt functions are vulnerable to Bleichenbacher-style attack when an attacker is able to provide the CMS or S/MIME messages and observe the error code and/or decryption output.

CVSS 3.1LOW 3.7 Network No auth No interaction EPSS 0.00801 Published 2026-06-09 Partial fix · 4.0.1, 3.6.3 +2 CWE-514
Priority LOW 18

Issue summary: When EVP_PKEY_derive_set_peer() is called with a DHX (X9.42) peer key, the peer key is not properly checked for the subgroup membership.

CVSS 3.1LOW 3.7 Network No auth No interaction EPSS 0.00503 Published 2026-06-09 Partial fix · 4.0.1, 3.6.3 +3 CWE-325