Red Hat Security AdvisoryRHSA-2026:34102
Insights proxy Container Image
Released 2026-07-01 · Red Hat rating Important · View on Red Hat →
Fixes 22 records
Priority HIGH 82
Calling the scanf family of functions with a %mc (malloc'd character match) in the GNU C Library version 2.7 to version 2.43 with a format width specifier with an explicit width greater than 1024 could result in a one by…
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00502 · Published 2026-04-20 · Partial fix CWE-122
Priority HIGH 72
An issue was discovered in xmllint (from libxml2) before 2.11.8 and 2.12.x before 2.12.7.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.018 · Published 2024-05-13 · Partial fix CWE-122
Priority MEDIUM 47
Issue summary: A specially crafted PKCS#7 or S/MIME signed message could trigger a use-after-free during PKCS#7 signature verification.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.04002 · Published 2026-06-09 · Partial fix · 4.0.1, 3.6.3 +5 CWE-416
Priority MEDIUM 47
Issue Summary: Cryptographic Message Services (CMS) processing fails to perform sufficient input validation on the cipher and tag length fields of AuthEnvelopedData containers, leading to various potential compromises.
CVSS 3.1CRITICAL 9.1· Network · No auth · No interaction · EPSS 0.01057 · Published 2026-06-09 · Fixed in 4.0.1, 3.6.3 +3 CWE-354
Priority MEDIUM 42
Stack-based buffer overflow in libtasn1 version: v4.20.0.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.0137 · Published 2026-01-07 · Partial fix CWE-787
Priority MEDIUM 41
Issue summary: Receiving a QUIC initial packet with an invalid token may trigger a NULL pointer dereference in the OpenSSL QUIC server with address validation disabled.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.01165 · Published 2026-06-09 · Partial fix · 4.0.1, 3.6.3 +1 CWE-476
Priority MEDIUM 41
Issue summary: Remote peer may exhaust heap memory of the QUIC server or client by flooding it with packets containing PATH_CHALLENGE frames.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.01049 · Published 2026-06-09 · Partial fix · 4.0.1, 3.6.3 +2 CWE-1325
Priority MEDIUM 41
Issue summary: Applications using RSASVE key encapsulation to establish a secret encryption key can send contents of an uninitialized memory buffer to a malicious peer.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.01049 · Published 2026-04-07 · Partial fix · 3.6.2, 3.5.6 +3 CWE-754
Priority MEDIUM 40
Issue summary: When an application drives an AES-OCB context through the public EVP_Cipher() one-shot interface, the application-supplied initialisation vector (IV) is silently discarded.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00704 · Published 2026-06-09 · Fixed in 4.0.1, 3.6.3 +3 CWE-325
Priority MEDIUM 40
Issue summary: When CMS password-based decryption (RFC 3211 / PWRI key unwrap) processes attacker-supplied CMS data, an attacker-chosen stream-mode KEK cipher can trigger a heap out-of-bounds read in kek_unwrap_key().
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00707 · Published 2026-06-09 · Partial fix · 4.0.1, 3.6.3 +5 CWE-125
Priority LOW 39
Issue summary: A signed integer overflow when sizing the destination buffer for Unicode output in ASN1_mbstring_ncopy() can lead to a heap buffer overflow.
CVSS 3.1HIGH 8.1· Network · No auth · No interaction · EPSS 0.00804 · Published 2026-06-09 · Partial fix · 4.0.1, 3.6.3 +5 CWE-787
Priority LOW 35
Issue summary: Parsing a crafted DER-encoded ASN.1 structure with a primitive element whose content exceeds 2 gigabytes in length may cause a heap buffer over-read on 64-bit Unix and Unix-like platforms.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.01025 · Published 2026-06-09 · Partial fix · 4.0.1, 3.6.3 +5 CWE-125
Priority LOW 33
Issue summary: An attacker-controlled CMP (Certificate Management Protocol) server could trigger a NULL pointer dereference in a CMP client application.
CVSS 3.1MEDIUM 5.9· Network · No auth · No interaction · EPSS 0.00557 · Published 2026-06-09 · Partial fix · 4.0.1, 3.6.3 +3 CWE-476
Priority LOW 33
Issue Summary: The PKCS#12 file processing fails to perform sufficient input validation for files that use Password-Based Message Authentication Code 1 (PBMAC1) integrity mechanism allowing a certificate and private key…
CVSS 3.1HIGH 7.4· Network · No auth · No interaction · EPSS 0.00376 · Published 2026-06-09 · Partial fix · 4.0.1, 3.6.3 +2 CWE-354
Priority LOW 32
Vim is an open source, command line text editor.
CVSS 3.1MEDIUM 6.6· Local · No auth · User interaction · EPSS 0.00501 · Published 2026-04-24 · Fixed in 9.2.0357 CWE-78
Priority LOW 30
Vim is an open source, command line text editor.
CVSS 3.1HIGH 7.1· Local · No auth · User interaction · EPSS 0.00131 · Published 2026-04-06 · Partial fix · 9.2.0280 CWE-22
Priority LOW 29
Issue summary: A specially crafted password-encrypted CMS message can trigger a NULL pointer dereference during CMS decryption.
CVSS 3.1MEDIUM 5.9· Network · No auth · No interaction · EPSS 0.0106 · Published 2026-06-09 · Partial fix · 4.0.1, 3.6.3 +5 CWE-476
Priority LOW 25
Issue Summary: An error in the callback used to verify the certificate provided in a Root CA key update Certificate Management Protocol (CMP) message response rendered the certificate validation ineffectual, which could…
CVSS 3.1MEDIUM 5.3· Network · Low privileges · No interaction · EPSS 0.00544 · Published 2026-06-09 · Partial fix · 4.0.1, 3.6.3 +2 CWE-295
Priority LOW 22
Issue summary: The implementations of AES-SIV (RFC 5297) and AES-GCM-SIV (RFC 8452) mishandle the authentication of AAD (Additional Authenticated Data) with an empty ciphertext allowing a forgery of such messages.
CVSS 3.1MEDIUM 4.8· Network · No auth · No interaction · EPSS 0.00439 · Published 2026-06-09 · Partial fix · 4.0.1, 3.6.3 +3 CWE-325
Priority LOW 20
A flaw was found in GNU Coreutils.
CVSS 3.1MEDIUM 4.4· Local · No auth · User interaction · EPSS 0.0031 · Published 2025-05-27 · Partial fix · 9.8, 9.5-8.el10_2 +33 CWE-121
Priority LOW 19
Issue summary: The CMS_decrypt and PKCS7_decrypt functions are vulnerable to Bleichenbacher-style attack when an attacker is able to provide the CMS or S/MIME messages and observe the error code and/or decryption output.
CVSS 3.1LOW 3.7· Network · No auth · No interaction · EPSS 0.00801 · Published 2026-06-09 · Partial fix · 4.0.1, 3.6.3 +2 CWE-514
Priority LOW 18
Issue summary: When EVP_PKEY_derive_set_peer() is called with a DHX (X9.42) peer key, the peer key is not properly checked for the subgroup membership.
CVSS 3.1LOW 3.7· Network · No auth · No interaction · EPSS 0.00503 · Published 2026-06-09 · Partial fix · 4.0.1, 3.6.3 +3 CWE-325