Read the docs
Red Hat Security Advisory

RHSA-2026:80644

Ansible plug-ins for Red Hat Developer Hub Product Release Update

Released 2026-10-12 · Red Hat rating Critical · View on Red Hat →

Fixed in

Fixes 27 records

Priority HIGH 82

vm2 through 3.12.0 (fixed in 3.12.1) does not correctly handle a nullish `this` receiver in the apply trap of its bridge (lib/bridge.js): when sandboxed code calls a host-provided non-strict (sloppy-mode) function withou…

CVSS 4.0CRITICAL 10.0 Network No auth No interaction EPSS 0.00726 Published 2026-09-18 Fixed in 3.12.1 CWE-94
Priority HIGH 82

vm2 before 3.11.6 fails to restrict access to os and dns builtins under the builtin: ['*'] configuration, allowing sandbox code to read host process identity and network topology.

CVSS 4.0CRITICAL 10.0 Network No auth No interaction EPSS 0.00474 Published 2026-09-17 Fixed in 3.11.6 CWE-200
TI-2026-62610 CVE-2026-92947 · GHSA-fcqc-726x-5wfc · GHSA-x5qg-8pq6-39h6

vm2 before 3.11.7 Memory Disclosure via Buffer Pool

Priority HIGH 82

vm2 before 3.11.7 exposes Node's shared Buffer pool to sandboxed code, allowing disclosure of host memory used by Buffer.from, Buffer.concat, and related allocations.

CVSS 4.0CRITICAL 10.0 Network No auth No interaction EPSS 0.00482 Published 2026-09-17 Fixed in 3.11.7 CWE-200
Priority HIGH 82

vm2 versions from 3.11.3 before 3.11.7 expose the host tls module to NodeVM sandbox code, allowing attackers to call tls.setDefaultCACertificates() and replace process-wide certificate authorities.

CVSS 4.0CRITICAL 10.0 Network No auth No interaction EPSS 0.00289 Published 2026-09-17 Fixed in 3.11.7 CWE-732
Priority HIGH 82

vm2 3.11.6 is vulnerable to a sandbox escape leading to remote code execution in the host Node.js process.

CVSS 4.0CRITICAL 10.0 Network No auth No interaction EPSS 0.01033 Published 2026-09-17 Fixed in 3.11.7 CWE-94
Priority HIGH 81

vm2 versions 3.10.2 through 3.11.6 contain a sandbox escape vulnerability on Node.js 26 where Promise.prototype.finally() bypasses vm2's wrapper protections due to a stale PromiseThenLookupChain protector in V8 14.6.

CVSS 4.0CRITICAL 9.3 Network No auth No interaction EPSS 0.00841 Published 2026-09-17 Fixed in 3.11.7 CWE-693
TI-2026-62616 CVE-2026-92953 · GHSA-3vgf-8m4q-q4qr · GHSA-5v7w-95g5-pj6q

vm2 3.11.0 through 3.11.7 Prototype Pollution via TypedArray

Priority HIGH 79

vm2 versions from 3.11.0 before 3.11.8 fail to protect host TypedArray and ArrayBuffer prototypes from sandbox mutation.

CVSS 4.0CRITICAL 9.3 Network No auth No interaction EPSS 0.00501 Published 2026-09-17 Fixed in 3.11.8 CWE-913
Priority HIGH 76

vm2 through 3.11.6 does not normalize `node:`-prefixed builtin specifiers when evaluating user-supplied negative (deny) entries in a NodeVM wildcard require policy.

CVSS 4.0CRITICAL 9.4 Network Low privileges No interaction EPSS 0.00537 Published 2026-09-17 Fixed in 3.11.7 CWE-269
Priority HIGH 76

vm2 versions >= 3.9.6 and <= 3.11.6 are affected by a NodeVM builtin allowlist bypass that permits a sandbox escape on Node.js 24 and newer when the embedder explicitly allows the node:test builtin (e.g.

CVSS 4.0CRITICAL 9.4 Network Low privileges No interaction EPSS 0.00654 Published 2026-09-17 Fixed in 3.11.7 CWE-693
Priority HIGH 76

vm2 versions 3.11.3 through 3.11.6 expose Node.js's host node:sqlite module to code running in NodeVM when that builtin is permitted, either explicitly or through builtin: ['*'].

CVSS 4.0CRITICAL 9.4 Network Low privileges No interaction EPSS 0.00616 Published 2026-09-17 Fixed in 3.11.7 CWE-693
TI-2026-62597 CVE-2026-92934 · GHSA-4xmw-hh9q-4q7c · GHSA-x965-fc75-jpqh

vm2 before 3.11.8 Sandbox Escape RCE via AggregateError

Priority HIGH 76

vm2 before 3.11.8 contains an incomplete fix for Error.cause sanitization that allows sandbox escape when revisited host-wrapped AggregateError objects are caught within a single exception handler traversal.

CVSS 4.0CRITICAL 9.5 Network No auth No interaction EPSS 0.00762 Published 2026-09-17 Fixed in 3.11.8 CWE-693
Priority HIGH 75

vm2 before 3.11.7 contains a sandbox escape vulnerability in the CLI tool that allows attackers to execute arbitrary code in the host Node.js process.

CVSS 4.0CRITICAL 9.3 Local No auth User interaction EPSS 0.00197 Published 2026-09-17 Fixed in 3.11.7 CWE-453
TI-2026-63068 CVE-2026-93604 · GHSA-qrp3-78q3-75rc

vm2 3.11.8 Sandbox Escape via crypto.setFips

Priority HIGH 70

vm2 through 3.12.0 exposes Node.js's crypto.setFips() function to untrusted guest code when an embedder explicitly allowlists the crypto builtin for a NodeVM (require.builtin: ['crypto']).

CVSS 4.0MEDIUM 6.9 Network No auth No interaction EPSS 0.00345 Published 2026-09-18 Fixed in 3.12.1 CWE-284
TI-2026-62609 CVE-2026-92946 · GHSA-29x6-9qh5-83gg · GHSA-j3hm-6rg5-mchv

vm2 before 3.11.7 Remote Code Execution via require.external

Priority MEDIUM 50

vm2 before 3.11.7 contains a remote code execution vulnerability when require.external is enabled without an explicit require.root that excludes node_modules.

CVSS 4.0CRITICAL 10.0 Network No auth No interaction EPSS 0.00776 Published 2026-09-17 Fixed in 3.11.7 CWE-913
TI-2026-63069 CVE-2026-93605 · GHSA-9hxx-m5g2-2q3h · GHSA-pq68-rvw4-xp4r

vm2 NodeVM before 3.12.1 Remote Code Execution via child_process

Priority MEDIUM 49

vm2 NodeVM versions before 3.12.1 contain a sandbox escape vulnerability where the DANGEROUS_BUILTINS denylist omits child_process despite blocking other host-spawning modules.

CVSS 4.0CRITICAL 10.0 Network No auth No interaction EPSS 0.0048 Published 2026-09-18 Fixed in 3.12.1 CWE-693
Priority MEDIUM 49

vm2 versions 3.11.3 through 3.11.6 expose the host process's real https.globalAgent to sandboxed code when a NodeVM is explicitly configured to allow require('https').

CVSS 4.0CRITICAL 10.0 Network No auth No interaction EPSS 0.00425 Published 2026-09-17 Fixed in 3.11.7 CWE-668
Priority MEDIUM 43

vm2 before 3.11.7 contains an incorrect authorization vulnerability in the external package allowlist check that uses non-exact substring matching instead of full package-name boundary validation.

CVSS 4.0CRITICAL 9.4 Network Low privileges No interaction EPSS 0.00468 Published 2026-09-17 Fixed in 3.11.7 CWE-706
TI-2026-65217 CVE-2026-101916 · GHSA-m9gg-hp2v-232j

Improper certificate validation in grpc-node

Priority LOW 34

@grpc/grpc-js implements the core functionality of gRPC purely in JavaScript, without a C++ addon.

CVSS 3.1HIGH 7.4 Network No auth No interaction EPSS 0.00215 Published 2026-09-28 Partial fix · 1.13.6, 1.14.5 CWE-295