Read the docs

Adobe

Records8047All Threatist records
Exploited (KEV)83In CISA KEV
CVSS critical1940CVSS 9.0–10.0
CVSS high3102CVSS 7.0–8.9

Exploited now

Adobe records in CISA KEV

Components

Products in the NVD configurations · select one to filter the records

Records

22 records in Dreamweaver · all components

Priority MEDIUM 41

Dreamweaver Desktop versions 21.6 and earlier are affected by an Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability that could lead in arbitrary code execution by an…

CVSS 3.1HIGH 8.6 Local No auth User interaction EPSS 0.0083 Published 2026-01-13 Fixed in 21.7 CWE-78
Priority MEDIUM 40

Adobe Dreamweaver direct download installer versions 19.0 and below, 18.0 and below have an Insecure Library Loading (DLL hijacking) vulnerability.

CVSS 3.0HIGH 7.8 Local No auth User interaction EPSS 0.03279 Published 2019-07-18 No fix listed CWE-427
Priority LOW 39

Dreamweaver Desktop versions 21.6 and earlier are affected by an Improper Input Validation vulnerability that could lead to arbitrary file system write.

CVSS 3.1HIGH 8.6 Local No auth User interaction EPSS 0.00234 Published 2026-01-13 Fixed in 21.7 CWE-20
Priority LOW 39

Dreamweaver Desktop versions 21.6 and earlier are affected by an Improper Input Validation vulnerability that could result in arbitrary code execution in the context of the current user.

CVSS 3.1HIGH 8.6 Local No auth User interaction EPSS 0.00255 Published 2026-01-13 Fixed in 21.7 CWE-20
Priority LOW 39

Dreamweaver Desktop versions 21.6 and earlier are affected by an Improper Input Validation vulnerability that could result in arbitrary code execution in the context of the current user.

CVSS 3.1HIGH 8.6 Local No auth User interaction EPSS 0.00255 Published 2026-01-13 Fixed in 21.7 CWE-20
Priority LOW 38

Dreamweaver Desktop versions 21.7 and earlier are affected by an Improper Access Control vulnerability that could result in arbitrary code execution in the context of the current user.

CVSS 3.1HIGH 8.6 Local No auth User interaction EPSS 0.00168 Published 2026-06-09 Fixed in 21.8 CWE-284
Priority LOW 38

Dreamweaver Desktop versions 21.7 and earlier are affected by a Dependency on Vulnerable Third-Party Component vulnerability that could result in arbitrary code execution in the context of the current user.

CVSS 3.1HIGH 8.6 Local No auth User interaction EPSS 0.00177 Published 2026-06-09 Fixed in 21.8 CWE-1395
Priority LOW 38

Dreamweaver Desktop versions 21.5 and earlier are affected by a Cross-Site Request Forgery (CSRF) vulnerability that could result in arbitrary code execution in the context of the current user.

CVSS 3.1HIGH 8.6 Local No auth User interaction EPSS 0.00171 Published 2025-09-09 No fix listed CWE-352
Priority LOW 38

Dreamweaver Desktop versions 21.3 and earlier are affected by an Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability that could lead in arbitrary code execution by an…

CVSS 3.1HIGH 7.8 Local No auth User interaction EPSS 0.00865 Published 2024-05-16 No fix listed CWE-78
Priority LOW 36

Dreamweaver Desktop versions 21.6 and earlier are affected by an Incorrect Authorization vulnerability that could result in arbitrary code execution in the context of the current user.

CVSS 3.1HIGH 7.8 Local No auth User interaction EPSS 0.00244 Published 2026-01-13 Fixed in 21.7 CWE-863
Priority LOW 36

Dreamweaver Desktop versions 21.4 and earlier are affected by an Access of Resource Using Incompatible Type ('Type Confusion') vulnerability that could result in arbitrary code execution in the context of the current use…

CVSS 3.1HIGH 7.8 Local No auth User interaction EPSS 0.00327 Published 2025-05-13 No fix listed CWE-843
Priority LOW 35

Dreamweaver Desktop versions 21.7 and earlier are affected by an Access of Uninitialized Pointer vulnerability that could result in arbitrary code execution in the context of the current user.

CVSS 3.1HIGH 7.8 Local No auth User interaction EPSS 0.00161 Published 2026-06-09 Fixed in 21.8 CWE-824
Priority LOW 35

Dreamweaver version 20.2 (and earlier) is affected by an uncontrolled search path element vulnerability that could lead to privilege escalation.

CVSS 3.1HIGH 7.8 Local Low privileges No interaction EPSS 0.00676 Published 2020-10-21 No fix listed CWE-427
Priority LOW 27

Dreamweaver Desktop versions 21.7 and earlier are affected by an Incorrect Authorization vulnerability that could lead to arbitrary file system read.

CVSS 3.1MEDIUM 6.3 Local No auth User interaction EPSS 0.00137 Published 2026-06-09 Fixed in 21.8 CWE-863
Priority LOW 27

Dreamweaver Desktop versions 21.7 and earlier are affected by an Improper Input Validation vulnerability that could lead to arbitrary file system read.

CVSS 3.1MEDIUM 6.3 Local No auth User interaction EPSS 0.00148 Published 2026-06-09 Fixed in 21.8 CWE-20
Open these records in search →