Dreamweaver Desktop | Improper Input Validation (CWE-20)
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Dreamweaver Desktop versions 21.6 and earlier are affected by an Improper Input Validation vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file and scope is changed.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Adobe | Adobe Dreamweaver Desktop | up to 21.6 | 21.7 | Patch available | CNA |
- Adobe Dreamweaver Desktop VendorAdobe Affected up to 21.6 Fixed in 21.7 Patch available CNA
Remediation
- Fix · CNA Adobe Dreamweaver Desktop (Adobe) Fixed in 21.7
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Adobe Dreamweaver Desktop — helpx.adobe.com/security/products/dreamweaver/apsb26-01.html
5 records Highest priority Priority MEDIUM 1 MEDIUM, 4 LOW
Other records, highest priority first
- TI-2026-17172 OS command injection in Adobe Dreamweaver DesktopPriority MEDIUM 41
- TI-2026-17176 Dreamweaver Desktop | Improper Input Validation (CWE-20)Priority LOW 39
- TI-2026-17175 Dreamweaver Desktop | Improper Input Validation (CWE-20)Priority LOW 39
Timeline
- 2026-10-02 Threatist record created from CVE-2026-21268
- 2026-10-03 Alias added: GHSA-wx29-4qhg-c2f3
References
More Adobe Dreamweaver vulnerabilities
- TI-2018-03492 OS command injection in Adobe Dreamweaver CC 18.0 and earlier versions CVSS 3.0CRITICAL 9.8
- TI-2010-02993 Untrusted search path vulnerability in Adobe Dreamweaver CS5 11.0 build 4916, build 4909… CVSS 2.0HIGH 9.3
- TI-2026-17172 OS command injection in Adobe Dreamweaver Desktop CVSS 3.1HIGH 8.6
- TI-2006-01987 Adobe Dreamweaver 8 before 8.0.2 and MX 2004 can generate code that allows SQL injection… CVSS 2.0HIGH 7.5
- TI-2019-05634 Uncontrolled search path in Adobe Dreamweaver CVSS 3.0HIGH 7.8
- TI-2026-17176 Dreamweaver Desktop | Improper Input Validation (CWE-20) CVSS 3.1HIGH 8.6
Sources
- CVE-2026-21268 · CVE Program
- CVE-2026-21268 · NVD
- FIRST EPSS
- GHSA-wx29-4qhg-c2f3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences