Read the docs

Angularjs

Records12All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical0CVSS 9.0–10.0
CVSS high3CVSS 7.0–8.9

Exploited now

Angularjs records in CISA KEV

No Angularjs vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

12 records

Priority MEDIUM 63

Versions of the package angular from 1.4.9 are vulnerable to Regular Expression Denial of Service (ReDoS) via the <input type="url"> element due to the usage of an insecure regular expression in the input[url] functional…

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.01695 Published 2023-03-30 No fix listed CWE-1333
Priority MEDIUM 63

Versions of the package angular from 1.0.0 are vulnerable to Regular Expression Denial of Service (ReDoS) via the $resource service due to the usage of an insecure regular expression.

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.01695 Published 2023-03-30 No fix listed CWE-1333
Priority MEDIUM 63

Versions of the package angular from 1.2.21 are vulnerable to Regular Expression Denial of Service (ReDoS) via the angular.copy() utility function due to the usage of an insecure regular expression.

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.01695 Published 2023-03-30 No fix listed CWE-1333
Priority MEDIUM 55

Improper sanitization of the value of the [srcset] attribute in <source> HTML elements in AngularJS allows attackers to bypass common image source restrictions, which can also lead to a form of Content Spoofing https://o…

CVSS 3.1MEDIUM 4.8 Network No auth No interaction EPSS 0.00635 Published 2024-09-09 No fix listed CWE-791
Priority MEDIUM 55

Improper sanitization of the value of the 'srcset' attribute in AngularJS allows attackers to bypass common image source restrictions, which can also lead to a form of Content Spoofing https://owasp.org/www-community/att…

CVSS 3.1MEDIUM 4.8 Network No auth No interaction EPSS 0.00609 Published 2024-09-09 No fix listed CWE-1289
Priority MEDIUM 41

The package angular after 1.7.0 are vulnerable to Regular Expression Denial of Service (ReDoS) by providing a custom locale rule that makes it possible to assign the parameter in posPre: ' '.repeat() of NUMBER_FORMATS.PA…

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.04927 Published 2022-05-01 No fix listed CWE-1333
TI-2022-09432 CVE-2022-25869 · GHSA-prc3-vjfx-vhm9

Cross-site scripting in angular

Priority LOW 38

All versions of the package angular; all versions of the package angularjs.core; all versions of the package angularjs are vulnerable to Cross-site Scripting (XSS) due to insecure page caching in the Internet Explorer br…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.0768 Published 2022-07-15 No fix listed CWE-79
Priority LOW 37

This affects versions of the package angular from 1.3.0; versions of the package angularjs from 1.3.0.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.01891 Published 2024-02-10 No fix listed CWE-1333
TI-2019-08033 CVE-2019-10768 · GHSA-89mq-4x47-5v83

Prototype pollution in AngularJS

Priority LOW 37

In AngularJS before 1.7.9 the function `merge()` could be tricked into adding or modifying properties of `Object.prototype` using a `__proto__` payload.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.01982 Published 2019-11-19 Partial fix · 1.7.9 CWE-1321
TI-2019-11067 CVE-2019-14863 · GHSA-r5fx-8r73-v86c

Cross-site scripting in Red Hat angular:

Priority LOW 30

There is a vulnerability in all angular versions before 1.5.0-beta.0, where after escaping the context of the web application, the web application delivers data to its users along with other trusted dynamic content, with…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.01198 Published 2020-01-02 Fixed in 1.5.0-beta.0, 1.5.0-beta.1 CWE-79
TI-2020-06196 CVE-2020-7676 · GHSA-mhp6-pxh8-r675

Cross-site scripting in angular.js

Priority LOW 28

angular.js prior to 1.8.0 allows cross site scripting.

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.01932 Published 2020-06-08 Partial fix · 1.8.0 CWE-79
TI-2021-03092 CVE-2021-4231 · GHSA-c75v-2vq8-878f

Angular Comment cross site scripting

Priority LOW 27

A vulnerability was found in Angular up to 11.0.4/11.1.0-next.2.

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.01181 Published 2022-05-26 Partial fix · 11.0.5, 11.1.0-next.3 +1 CWE-79
Open these records in search →