Angular Comment cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 1 fixed, 9 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
A vulnerability was found in Angular up to 11.0.4/11.1.0-next.2. It has been classified as problematic. Affected is the handling of comments. The manipulation leads to cross site scripting. It is possible to launch the attack remotely but it might require an authentication first. Upgrading to version 11.0.5 and 11.1.0-next.3 is able to address this issue. The name of the patch is ba8da742e3b243e8f43d4c63aa842b44e14f2b09. It is recommended to upgrade the affected component.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| unspecified | Angular | 11.0.0; 11.0.1; 11.0.2; 11.0.3; 11.0.4; 11.1.0-next.0; 11.1.0-next.1; 11.1.0-next.2 | — | No fix listed | CNA |
| — | @angular/core (npm) | 11.0.0 to before 11.0.5 | 11.0.5 | Patch available | GHSA-c75v-2vq8-878f |
| — | @angular/core (npm) | 11.1.0-next.0 to before 11.1.0-next.3 | 11.1.0-next.3 | Patch available | GHSA-c75v-2vq8-878f |
| — | @angular/core (npm) | before 10.2.5 | 10.2.5 | Patch available | GHSA-c75v-2vq8-878f |
- Angular Vendorunspecified Affected 11.0.0; 11.0.1; 11.0.2; 11.0.3; 11.0.4; 11.1.0-next.0; 11.1.0-next.1; 11.1.0-next.2 Fixed in — No fix listed CNA
- @angular/core (npm) Vendor— Affected 11.0.0 to before 11.0.5 Fixed in 11.0.5 Patch available GHSA-c75v-2vq8-878f
- @angular/core (npm) Vendor— Affected 11.1.0-next.0 to before 11.1.0-next.3 Fixed in 11.1.0-next.3 Patch available GHSA-c75v-2vq8-878f
- @angular/core (npm) Vendor— Affected before 10.2.5 Fixed in 10.2.5 Patch available GHSA-c75v-2vq8-878f
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:angular:angular:11.1.0:next0:*:*:*:*:*:* | 11.1.0 next0 | Vulnerable | angular |
| cpe:2.3:a:angular:angular:11.1.0:next1:*:*:*:*:*:* | 11.1.0 next1 | Vulnerable | angular |
| cpe:2.3:a:angular:angular:11.1.0:next2:*:*:*:*:*:* | 11.1.0 next2 | Vulnerable | angular |
| cpe:2.3:a:angularjs:angularjs:*:*:*:*:*:*:*:* | before 11.0.5 | Vulnerable | Angularjs |
- cpe:2.3:a:angular:angular:11.1.0:next0:*:*:*:*:*:* Versions 11.1.0 next0 Vulnerable ·angular
- cpe:2.3:a:angular:angular:11.1.0:next1:*:*:*:*:*:* Versions 11.1.0 next1 Vulnerable ·angular
- cpe:2.3:a:angular:angular:11.1.0:next2:*:*:*:*:*:* Versions 11.1.0 next2 Vulnerable ·angular
- cpe:2.3:a:angularjs:angularjs:*:*:*:*:*:*:*:* Versions before 11.0.5 Vulnerable ·Angularjs
Remediation
- Fix · GHSA-c75v-2vq8-878f @angular/core (npm) Fixed in 11.0.5 Advisory →
- Fix · GHSA-c75v-2vq8-878f @angular/core (npm) Fixed in 11.1.0-next.3 Advisory →
- Fix · GHSA-c75v-2vq8-878f @angular/core (npm) Fixed in 10.2.5 Advisory →
Red Hat 1 advisory
- RHSA-2023:3623 Released 2023-06-15 · Red Hat rating ModerateRed Hat Ceph Storage 6.1 security and bug fix update
- Red Hat Ceph Storage 6.1 Tools ansible-collection-ansible-posix-1.2.0-1.3.el9ost, ceph-2:17.2.6-70.el9cp, ceph-base-2:17.2.6-70.el9cp +26
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| .NET Core 3.1 on Red Hat Enterprise Linux | Affected | No fix yet: Fix deferred |
| .NET Core 5.0 on Red Hat Enterprise Linux | Affected | No fix planned: Out of support scope |
| Red Hat Ceph Storage 4 | Affected | No fix yet |
| Red Hat Ceph Storage 5 | Affected | No fix yet |
| Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
| Red Hat Fuse 7 | Affected | No fix yet: Fix deferred |
| Red Hat Openshift Container Storage 4 | Affected | No fix planned: Out of support scope |
| Red Hat Openshift Data Foundation 4 | Affected | No fix yet |
| Red Hat Ceph Storage 6.1 Tools | Fixed | RHSA-2023:3623 |
Not affected: 4 products
- Red Hat Ceph Storage 6.1 Tools
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2021-4231
- 2026-10-03 Alias added: GHSA-c75v-2vq8-878f
References
Advisory 2
Sources
- CVE-2021-4231 · CVE Program
- CVE-2021-4231 · NVD
- FIRST EPSS
- GHSA-c75v-2vq8-878f · GitHub Advisory Database · CC BY 4.0
- CVE-2021-4231 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences