Priority HIGH 78
Bludit 3.9.2 allows remote code execution via bl-kernel/ajax/upload-images.php because PHP code can be entered with a .jpg file name, and then this PHP code can write other PHP code to a ../ pathname.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.78109 · Published 2019-09-08 · No fix listed CWE-22
Priority HIGH 74
A security vulnerability has been identified in Bludit, allowing authenticated attackers to execute arbitrary code through the Image API.
CVSS 4.0HIGH 8.9· Network · High privileges · No interaction · EPSS 0.00755 · Published 2024-06-24 · No fix listed CWE-434
Priority HIGH 74
A security vulnerability has been identified in Bludit, allowing attackers with knowledge of the API token to upload arbitrary files through the File API which leads to arbitrary code execution on the server.
CVSS 4.0HIGH 8.9· Network · High privileges · No interaction · EPSS 0.00692 · Published 2024-06-24 · No fix listed CWE-434
Priority HIGH 73
An issue in Bludit 4.0.0-rc-2 allows authenticated attackers to change the Administrator password and escalate privileges via a crafted request.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.00844 · Published 2023-05-16 · No fix listed
Priority HIGH 73
Bludit 3.9.2 is vulnerable to Remote Code Execution (RCE) via /admin/ajax/upload-images.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.01263 · Published 2023-06-26 · No fix listed CWE-434
Priority HIGH 70
bl-kernel/security.class.php in Bludit 3.9.2 allows attackers to bypass a brute-force protection mechanism by using many different forged X-Forwarded-For or Client-IP HTTP headers.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.40683 · Published 2019-10-06 · No fix listed CWE-307
Priority HIGH 69
Permissions vulnerability found in Bludit CMS v.4.0.0 allows local attackers to escalate privileges via the role:admin parameter.
CVSS 3.1HIGH 7.8· Local · Low privileges · No interaction · EPSS 0.00237 · Published 2023-09-01 · No fix listed CWE-862
Priority HIGH 68
bludit version 3.0.0 contains a Unrestricted Upload of File with Dangerous Type vulnerability in Content Upload in Pages Editor that can result in Remote Command Execution.
CVSS 3.0HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.47645 · Published 2018-12-20 · No fix listed CWE-434
Priority MEDIUM 58
Bludit v3.14.1 is vulnerable to Stored Cross Site Scripting (XSS) via SVG file on site logo.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.02586 · Published 2023-05-17 · No fix listed CWE-79
Priority MEDIUM 58
A vulnerability was found in Bludit 3.13.1.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00676 · Published 2022-05-05 · No fix listed CWE-79
Priority MEDIUM 56
Bludit version 3.16.1 contains a cross-site request forgery (CSRF) vulnerability in the /admin/uninstall-plugin/ and /admin/install-theme/ endpoints.
CVSS 4.0MEDIUM 5.1· Network · No auth · User interaction · EPSS 0.00171 · Published 2026-02-23 · No fix listed CWE-352
Priority MEDIUM 55
Cross Site Scripting (XSS) vulnerability in Bludit CMS version 3.15, allows remote attackers to execute arbitrary code and obtain sensitive information via edit-content.php.
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00566 · Published 2024-02-17 · No fix listed CWE-79
Priority MEDIUM 55
Cross Site Scripting Vulnerability in BluditCMS v.3.14.1 allows attackers to execute arbitrary code via the Categories Friendly URL.
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00511 · Published 2023-09-01 · No fix listed CWE-79
Priority MEDIUM 48
Unrestricted File Upload in Bludit v3.8.1 allows remote attackers to execute arbitrary code by uploading malicious files via the component 'bl-kereln/ajax/upload-logo.php'.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.03133 · Published 2021-08-20 · No fix listed CWE-434
Priority MEDIUM 44
Bludit’s API plugin allows an authenticated attacker with a valid API token to upload files of any type and extension without restriction, which can then be executed, leading to Remote Code Execution.
CVSS 4.0HIGH 8.7· Network · Low privileges · No interaction · EPSS 0.01993 · Published 2026-03-27 · Fixed in 3.18.4 CWE-434
Priority MEDIUM 43
Bludit v3.8.1 is affected by directory traversal.
CVSS 3.1CRITICAL 9.1· Network · No auth · No interaction · EPSS 0.01961 · Published 2020-10-02 · No fix listed CWE-22
Priority MEDIUM 43
Bludit before 3.9.0 allows remote code execution for an authenticated user by uploading a php file while changing the logo through /admin/ajax/upload-logo.
CVSS 3.0HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.02988 · Published 2019-06-03 · No fix listed CWE-434
Priority MEDIUM 42
bludit v3.13.0 contains an arbitrary file deletion vulnerability in the backup plugin via the `deleteBackup' parameter.
CVSS 3.1CRITICAL 9.1· Network · No auth · No interaction · EPSS 0.01509 · Published 2021-08-31 · No fix listed
Priority MEDIUM 41
Bludit prior to 3.9.1 allows a non-privileged user to change the password of any account, including admin.
CVSS 3.0HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.0128 · Published 2019-06-05 · No fix listed CWE-639
Priority LOW 36
A code injection vulnerability in backup/plugin.php of Bludit 3.13.1 allows attackers to execute arbitrary code via a crafted ZIP file.
CVSS 3.1HIGH 7.8· Local · No auth · User interaction · EPSS 0.01215 · Published 2021-07-23 · No fix listed CWE-94
Priority LOW 35
Cross Site Scripting (XSS) vulnerability exists in bludit 3-13-1 via the username in admin/login.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.05091 · Published 2021-10-19 · No fix listed CWE-79
Priority LOW 34
A file upload vulnerability was discovered in the file path /bl-plugins/backup/plugin.php on Bludit version 3.12.0.
CVSS 3.1HIGH 7.2· Network · High privileges · No interaction · EPSS 0.01102 · Published 2021-05-21 · No fix listed CWE-434
Priority LOW 34
An issue was found in bludit v3.13.0, unsafe implementation of the backup plugin allows attackers to upload arbitrary files.
CVSS 3.1HIGH 7.2· Network · High privileges · No interaction · EPSS 0.01244 · Published 2022-05-11 · No fix listed CWE-434
Priority LOW 33
Bludit versions before 3.13.0 contain an authenticated file download vulnerability in the Backup Plugin that allows logged-in users to access arbitrary files.
CVSS 4.0HIGH 7.1· Network · Low privileges · No interaction · EPSS 0.00811 · Published 2025-12-17 · Fixed in 3.13.0 CWE-22
Priority LOW 28
Bludit uses the SHA-1 hashing algorithm to compute password hashes.
CVSS 4.0MEDIUM 5.9· Network · High privileges · No interaction · EPSS 0.00217 · Published 2024-06-24 · No fix listed CWE-916
Load more