Bludit < 3.13.0 Authenticated Arbitrary File Download via Backup Plugin
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-22 and the CVSS impact.
Summary
Bludit versions before 3.13.0 contain an authenticated file download vulnerability in the Backup Plugin that allows logged-in users to access arbitrary files. Attackers can exploit the plugin's download functionality by manipulating file path parameters to read sensitive system files through directory traversal.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Backup Plugin (Bludit) Fixed in 3.13.0
Timeline
- 2026-10-02 Threatist record created from CVE-2023-53907
- 2026-10-03 Alias added: GHSA-c3xc-px9v-223r
- 2026-10-29 Title updated · CNA
- 2026-10-29 Fix available: Bludit/Backup [email protected] · CNA
References
Exploit 1
Other 1
More Bludit vulnerabilities
- TI-2019-12105 Bludit 3.9.2 allows remote code execution via bl-kernel/ajax/upload-images.php because… CVSS 3.1HIGH 8.8
- TI-2024-16173 Bludit - Remote Code Execution (RCE) through Image API CVSS 4.0HIGH 8.9
- TI-2024-16172 Bludit - Remote Code Execution (RCE) through File API CVSS 4.0HIGH 8.9
- TI-2023-15122 An issue in Bludit 4.0.0-rc-2 allows authenticated attackers to change the Administrator… CVSS 3.1HIGH 8.8
- TI-2020-13782 Bludit 3.9.2 is vulnerable to Remote Code Execution (RCE) via /admin/ajax/upload-images. CVSS 3.1HIGH 8.8
- TI-2019-12856 bl-kernel/security.class.php in Bludit 3.9.2 allows attackers to bypass a brute-force… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-53907 · CVE Program
- CVE-2023-53907 · NVD
- FIRST EPSS
- GHSA-c3xc-px9v-223r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences