Read the docs

ultimateblocks

Records16All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical0CVSS 9.0–10.0
CVSS high0CVSS 7.0–8.9

Exploited now

ultimateblocks records in CISA KEV

No ultimateblocks vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

9 records in Ultimate Blocks · all components

Priority MEDIUM 61

The Ultimate Blocks WordPress plugin before 3.1.9 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor r…

CVSS 3.1MEDIUM 6.3 Network No auth User interaction EPSS 0.00447 Published 2024-07-11 Fixed in 3.1.9 CWE-79
Priority MEDIUM 58

The Ultimate Blocks WordPress plugin before 3.2.4 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor r…

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00295 Published 2024-12-13 Fixed in 3.2.4 CWE-79
Priority MEDIUM 58

The Ultimate Blocks WordPress plugin before 3.2.2 does not validate and escape some of its block attributes before outputting them back in a page/post where the block is embed, which could allow users with the contributo…

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00377 Published 2024-09-30 Fixed in 3.2.2 CWE-79
Priority MEDIUM 54

The Ultimate Blocks WordPress plugin before 3.2.0 does not validate and escape some of its post-grid block attributes before outputting them back in a page/post where the block is embed, which could allow users with the…

CVSS 3.1MEDIUM 4.6 Network Low privileges User interaction EPSS 0.00318 Published 2024-07-29 Fixed in 3.2.0 CWE-79
Priority LOW 29

The Ultimate Blocks – WordPress Blocks Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's blocks in all versions up to, and including, 3.1.9 due to insufficient input sanitization a…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00489 Published 2024-07-02 No fix listed CWE-79
Priority LOW 28

The Ultimate Blocks – WordPress Blocks Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via multiple widgets in all versions up to, and including, 3.3.3 due to insufficient input sanitization and…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00282 Published 2025-06-10 No fix listed CWE-79
Priority LOW 28

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Ultimate Blocks Ultimate Blocks – Gutenberg Blocks Plugin allows Stored XSS.This issue affects Ultimate Blocks…

CVSS 3.1MEDIUM 6.5 Network Low privileges User interaction EPSS 0.00237 Published 2024-07-21 No fix listed CWE-79
Priority LOW 28

The Ultimate Blocks – WordPress Blocks Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the title tag (postTitleTag) parameter in all versions up to, and including, 3.1.9 due to insufficient i…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00279 Published 2024-07-02 No fix listed CWE-79
Priority LOW 24

The Ultimate Blocks WordPress plugin before 3.1.7 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor r…

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.00353 Published 2024-05-14 Fixed in 3.1.7 CWE-79
Open these records in search →