Ultimate Blocks < 3.1.9 - Contributor+ Stored XSS
Priority MEDIUM 61CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Ultimate Blocks WordPress plugin before 3.1.9 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00447 39th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Ultimate Blocks (Unknown): 3.1.9
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Ultimate Blocks | before 3.1.9 | 3.1.9 | Patch available | CNA |
- Ultimate Blocks VendorUnknown Affected before 3.1.9 Fixed in 3.1.9 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:dotcamp:ultimate_blocks:*:*:*:*:*:wordpress:*:* | before 3.1.9 | Vulnerable | ultimateblocks |
- cpe:2.3:a:dotcamp:ultimate_blocks:*:*:*:*:*:wordpress:*:* Versions before 3.1.9 Vulnerable ·ultimateblocks
Remediation
- Fix · CNA Ultimate Blocks (Unknown) Fixed in 3.1.9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-4655
- 2026-10-03 Alias added: GHSA-f87m-vvg7-6xrc
References
More ultimateblocks Ultimate Blocks vulnerabilities
- TI-2024-09896 Ultimate Blocks < 3.2.4 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2024-07913 Ultimate Blocks < 3.2.2 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2024-05904 Ultimate Blocks < 3.2.0 - Contributor+ Stored XSS CVSS 3.1MEDIUM 4.6
- TI-2024-03973 Cross-site scripting in ultimateblocks Ultimate Blocks – 25+ Gutenberg Blocks for Block… CVSS 3.1MEDIUM 6.4
- TI-2025-02549 Cross-site scripting in ultimateblocks Ultimate Blocks – 25+ Gutenberg Blocks for Block… CVSS 3.1MEDIUM 6.4
- TI-2024-24961 WordPress Ultimate Blocks – WordPress Blocks Plugin plugin <= 3.1.9 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
Sources
- CVE-2024-4655 · CVE Program
- CVE-2024-4655 · NVD
- FIRST EPSS
- GHSA-f87m-vvg7-6xrc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences