Versions of the package geokit-rails before 2.5.0 are vulnerable to Command Injection due to unsafe deserialisation of YAML within the 'geo_location' cookie.
CVSS 3.1CRITICAL 9.8·Network·No auth·No interaction·EPSS 0.03847·Published 2023-10-06·Fixed in 2.5.0CWE-78