OS command injection in geokit-rails
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
Versions of the package geokit-rails before 2.5.0 are vulnerable to Command Injection due to unsafe deserialisation of YAML within the 'geo_location' cookie. This issue can be exploited remotely via a malicious cookie value. **Note:** An attacker can use this vulnerability to execute commands on the host system.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | geokit-rails | before 2.5.0 | 2.5.0 | Patch available | CNA |
| — | geokit-rails (RubyGems) | before 2.5.0 | 2.5.0 | Patch available | GHSA-7xvc-v44j-46fh |
- geokit-rails Vendor— Affected before 2.5.0 Fixed in 2.5.0 Patch available CNA
- geokit-rails (RubyGems) Vendor— Affected before 2.5.0 Fixed in 2.5.0 Patch available GHSA-7xvc-v44j-46fh
Remediation
- Fix · CNA geokit-rails Fixed in 2.5.0
- Fix · GHSA-7xvc-v44j-46fh geokit-rails (RubyGems) Fixed in 2.5.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-26153
- 2026-10-03 Alias added: GHSA-7xvc-v44j-46fh
- 2026-10-18 EPSS moved to the 90th–95th percentile
References
Patch 2
Advisory 2
Other 4
- https://github.com/geokit/geokit-rails/blob/master/lib/geokit-rails/ip_geocode_lookup.rb%23L37
- https://github.com/geokit/geokit-rails
- https://github.com/geokit/geokit-rails/blob/master/lib/geokit-rails/ip_geocode_lookup.rb#L37
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/geokit-rails/CVE-2023-26153.yml
Sources
- CVE-2023-26153 · CVE Program
- CVE-2023-26153 · NVD
- FIRST EPSS
- GHSA-7xvc-v44j-46fh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences