Read the docs

GFI Software

Records64All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical8CVSS 9.0–10.0
CVSS high14CVSS 7.0–8.9

Exploited now

GFI Software records in CISA KEV

No GFI Software vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

22 records in Mailessentials · all components

Priority HIGH 69

GFI MailEssentials prior to version 21.8 is vulnerable to a local privilege escalation issue.

CVSS 3.1HIGH 7.8 Local Low privileges No interaction EPSS 0.00327 Published 2025-04-28 Fixed in 21.8 CWE-502
Priority LOW 30

GFI MailEssentials prior to version 21.8 is vulnerable to an XML External Entity (XXE) issue.

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.00729 Published 2025-04-28 Fixed in 21.8 CWE-611
Priority LOW 24

GFI MailEssentials AI versions prior to 22.4 contain an arbitrary directory existence enumeration vulnerability in the ListServer.IsPathExist() web method exposed at /MailEssentials/pages/MailSecurity/ListServer.aspx/IsP…

CVSS 4.0MEDIUM 5.3 Network Low privileges No interaction EPSS 0.00283 Published 2026-02-19 Fixed in 22.4 CWE-203
Priority LOW 23

GFI MailEssentials AI versions prior to 22.4 contain an arbitrary file existence enumeration vulnerability in the ListServer.IsDBExist() web method exposed at /MailEssentials/pages/MailSecurity/ListServer.aspx/IsDBExist.

CVSS 4.0MEDIUM 5.3 Network Low privileges No interaction EPSS 0.00213 Published 2026-02-19 Fixed in 22.4 CWE-203
Priority LOW 23

GFI MailEssentials AI versions prior to 22.4 contain a stored cross-site scripting vulnerability in the Advanced Content Filtering rule creation workflow.

CVSS 4.0MEDIUM 5.1 Network Low privileges User interaction EPSS 0.00206 Published 2026-02-19 Fixed in 22.4 CWE-79
Priority LOW 23

GFI MailEssentials AI versions prior to 22.4 contain a stored cross-site scripting vulnerability in the Attachment Filtering rule creation workflow.

CVSS 4.0MEDIUM 5.1 Network Low privileges User interaction EPSS 0.00206 Published 2026-02-19 Fixed in 22.4 CWE-79
Priority LOW 23

GFI MailEssentials AI versions prior to 22.4 contain a stored cross-site scripting vulnerability in the Keyword Filtering rule creation workflow.

CVSS 4.0MEDIUM 5.1 Network Low privileges User interaction EPSS 0.00206 Published 2026-02-19 Fixed in 22.4 CWE-79
Open these records in search →