Read the docs

Git-scm

Records41All Threatist records
Exploited (KEV)1In CISA KEV
CVSS critical9CVSS 9.0–10.0
CVSS high24CVSS 7.0–8.9

Exploited now

Git-scm records in CISA KEV

Components

Products in the NVD configurations · select one to filter the records

Records

41 records

Priority CRITICAL 94KEV

Git is a fast, scalable, distributed revision control system with an unusually rich command set that provides both high-level operations and full access to internals.

CVSS 3.1HIGH 8.1 Network Low privileges User interaction EPSS 0.04379 Published 2025-07-08 Partial fix · 2.43.7, 2.44.4 +6 CWE-436
Priority CRITICAL 87

Git before 2.14.5, 2.15.x before 2.15.3, 2.16.x before 2.16.5, 2.17.x before 2.17.2, 2.18.x before 2.18.1, and 2.19.x before 2.19.1 allows remote code execution during processing of a recursive "git clone" of a superproj…

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.97356 Published 2018-10-06 Partial fix CWE-88
Priority HIGH 81

Git before 1.8.5.6, 1.9.x before 1.9.5, 2.0.x before 2.0.5, 2.1.x before 2.1.4, and 2.2.x before 2.2.1 on Windows and OS X; Mercurial before 3.2.3 on Windows and OS X; Apple Xcode before 6.2 beta 3; mine all versions bef…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.75597 Published 2020-02-12 Fixed in 3.5.3, 3.2.3 CWE-20
Priority MEDIUM 64

Git before 2.10.5, 2.11.x before 2.11.4, 2.12.x before 2.12.5, 2.13.x before 2.13.6, and 2.14.x before 2.14.2 uses unsafe Perl scripts to support subcommands such as cvsserver, which allows attackers to execute arbitrary…

CVSS 3.0HIGH 8.8 Network Low privileges No interaction EPSS 0.36003 Published 2017-09-28 Will not fix CWE-78
Priority MEDIUM 41

Git, a revision control system, is vulnerable to path traversal prior to versions 2.39.2, 2.38.4, 2.37.6, 2.36.5, 2.35.7, 2.34.7, 2.33.7, 2.32.6, 2.31.7, and 2.30.8.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.01135 Published 2023-02-14 Partial fix · 2.39.2, 2.38.4 +8 CWE-22
Priority MEDIUM 40

Arbitrary command execution is possible in Git before 2.20.2, 2.21.x before 2.21.1, 2.22.x before 2.22.2, 2.23.x before 2.23.1, and 2.24.x before 2.24.1 because a "git submodule update" operation can run commands found i…

CVSS 3.1HIGH 7.8 Local No auth User interaction EPSS 0.03707 Published 2019-12-10 No fix listed CWE-78
Load more
Open these records in search →