Git vulnerable to Remote Code Execution while cloning special-crafted local repositories
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 12 fixed, 3 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat.
Summary
Git is a revision control system. Prior to versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4, an attacker can prepare a local repository in such a way that, when cloned, will execute arbitrary code during the operation. The problem has been patched in versions 2.45.1, 2.44.1, 2.43.4, 2.42.2, 2.41.1, 2.40.2, and 2.39.4. As a workaround, avoid cloning repositories from untrusted sources.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Git | git | = 2.45.0; = 2.44.0; 2.43.0 to before 2.43.4; 2.42.0 to before 2.42.2; = 2.41.0; 2.40.0 to before 2.40.2; before 2.39.4 | 2.43.4, 2.42.2, 2.40.2, 2.39.4 | Patch available | CNA |
- git VendorGit Affected = 2.45.0; = 2.44.0; 2.43.0 to before 2.43.4; 2.42.0 to before 2.42.2; = 2.41.0; 2.40.0 to before 2.40.2; before 2.39.4 Fixed in 2.43.4, 2.42.2, 2.40.2, 2.39.4 Patch available CNA
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:git-scm:git:*:*:*:*:*:*:*:* | before 2.39.4; 2.40.0 to before 2.40.2; 2.42.0 to before 2.42.2; 2.43.0 to before 2.43.4 | Vulnerable | Git-scm |
| cpe:2.3:a:git-scm:git:2.41.0:*:*:*:*:*:*:* | 2.41.0 | Vulnerable | Git-scm |
| cpe:2.3:a:git-scm:git:2.44.0:*:*:*:*:*:*:* | 2.44.0 | Vulnerable | Git-scm |
| cpe:2.3:a:git-scm:git:2.45.0:*:*:*:*:*:*:* | 2.45.0 | Vulnerable | Git-scm |
| cpe:2.3:o:fedoraproject:fedora:40:*:*:*:*:*:*:* | 40 | Vulnerable | Fedoraproject |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
- cpe:2.3:a:git-scm:git:*:*:*:*:*:*:*:* Versions before 2.39.4; 2.40.0 to before 2.40.2; 2.42.0 to before 2.42.2; 2.43.0 to before 2.43.4 Vulnerable ·Git-scm
- cpe:2.3:a:git-scm:git:2.41.0:*:*:*:*:*:*:* Versions 2.41.0 Vulnerable ·Git-scm
- cpe:2.3:a:git-scm:git:2.44.0:*:*:*:*:*:*:* Versions 2.44.0 Vulnerable ·Git-scm
- cpe:2.3:a:git-scm:git:2.45.0:*:*:*:*:*:*:* Versions 2.45.0 Vulnerable ·Git-scm
- cpe:2.3:o:fedoraproject:fedora:40:*:*:*:*:*:*:* Versions 40 Vulnerable ·Fedoraproject
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
Remediation
- Fix · CNA git (git) Fixed in 2.43.4, 2.42.2, 2.40.2, 2.39.4
Red Hat 8 advisories
- RHSA-2024:7701 Released 2024-10-07 · Red Hat rating Importantgit security update
- Red Hat Enterprise Linux AppStream AUS (v. 8.2) git-2.18.4-5.el8_2, git-all-2.18.4-5.el8_2, git-core-2.18.4-5.el8_2 +11
- RHSA-2024:6610 Released 2024-09-11 · Red Hat rating Importantgit security update
- Red Hat Enterprise Linux AppStream E4S (v.9.0) git-2.31.1-6.el9_0, git-all-2.31.1-6.el9_0, git-core-2.31.1-6.el9_0 +12
- RHSA-2024:6027 Released 2024-08-29 · Red Hat rating Importantgit security update
- Red Hat Enterprise Linux AppStream AUS (v.8.6) git-2.31.8-3.el8_6, git-all-2.31.8-3.el8_6, git-core-2.31.8-3.el8_6 +12
- Red Hat Enterprise Linux AppStream E4S (v.8.6) git-2.31.8-3.el8_6, git-all-2.31.8-3.el8_6, git-core-2.31.8-3.el8_6 +12
- Red Hat Enterprise Linux AppStream TUS (v.8.6) git-2.31.8-3.el8_6, git-all-2.31.8-3.el8_6, git-core-2.31.8-3.el8_6 +12
Show 5 more Red Hat advisories
- RHSA-2024:6028 Released 2024-08-29 · Red Hat rating Importantgit security update
- Red Hat Enterprise Linux AppStream AUS (v.8.4) git-2.27.0-5.el8_4, git-all-2.27.0-5.el8_4, git-core-2.27.0-5.el8_4 +12
- Red Hat Enterprise Linux AppStream E4S (v.8.4) git-2.27.0-5.el8_4, git-all-2.27.0-5.el8_4, git-core-2.27.0-5.el8_4 +12
- Red Hat Enterprise Linux AppStream TUS (v.8.4) git-2.27.0-5.el8_4, git-all-2.27.0-5.el8_4, git-core-2.27.0-5.el8_4 +12
- RHSA-2024:4579 Released 2024-07-16 · Red Hat rating Importantgit security update
- Red Hat Enterprise Linux AppStream EUS (v.8.8) git-2.39.5-1.el8_8, git-all-2.39.5-1.el8_8, git-core-2.39.5-1.el8_8 +12
- RHSA-2024:4368 Released 2024-07-08 · Red Hat rating Importantgit security update
- Red Hat Enterprise Linux AppStream EUS (v.9.2) git-2.39.5-1.el9_2, git-all-2.39.5-1.el9_2, git-core-2.39.5-1.el9_2 +12
- RHSA-2024:4083 Released 2024-06-25 · Red Hat rating Importantgit security update
- Red Hat Enterprise Linux AppStream (v. 9) git-2.43.5-1.el9_4, git-all-2.43.5-1.el9_4, git-core-2.43.5-1.el9_4 +12
- RHSA-2024:4084 Released 2024-06-25 · Red Hat rating Importantgit security update
- Red Hat Enterprise Linux AppStream (v. 8) git-2.43.5-1.el8_10, git-all-2.43.5-1.el8_10, git-core-2.43.5-1.el8_10 +12
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Fuse 7 | Affected | No fix planned: Out of support scope |
| Red Hat Software Collections | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2024:4084 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2024:4083 |
| Red Hat Enterprise Linux AppStream AUS (v. 8.2) | Fixed | RHSA-2024:7701 |
| Red Hat Enterprise Linux AppStream AUS (v.8.4) | Fixed | RHSA-2024:6028 |
| Red Hat Enterprise Linux AppStream AUS (v.8.6) | Fixed | RHSA-2024:6027 |
| Red Hat Enterprise Linux AppStream E4S (v.8.4) | Fixed | RHSA-2024:6028 |
| Red Hat Enterprise Linux AppStream E4S (v.8.6) | Fixed | RHSA-2024:6027 |
| Red Hat Enterprise Linux AppStream E4S (v.9.0) | Fixed | RHSA-2024:6610 |
| Red Hat Enterprise Linux AppStream EUS (v.8.8) | Fixed | RHSA-2024:4579 |
| Red Hat Enterprise Linux AppStream EUS (v.9.2) | Fixed | RHSA-2024:4368 |
| Red Hat Enterprise Linux AppStream TUS (v.8.4) | Fixed | RHSA-2024:6028 |
| Red Hat Enterprise Linux AppStream TUS (v.8.6) | Fixed | RHSA-2024:6027 |
Not affected: 2 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 7
Timeline
- 2026-10-02 Threatist record created from CVE-2024-32004
References
Advisory 5
- https://github.com/git/git/security/advisories/GHSA-xfc6-vwr8-r389
- https://lists.fedoraproject.org/archives/list/[email protected]/message/S4CK4IYTXEOBZTEM5K3T6LWOIZ3S44AR/
- http://www.openwall.com/lists/oss-security/2024/05/14/2
- https://lists.debian.org/debian-lts-announce/2024/06/msg00018.html
- https://lists.debian.org/debian-lts-announce/2024/09/msg00009.html
More Git vulnerabilities
- TI-2025-30709 Git allows arbitrary code execution through broken config quoting KEVCVSS 3.1HIGH 8.1
- TI-2022-07580 gitattributes parsing integer overflow in git CVSS 3.1CRITICAL 9.8
- TI-2022-20244 Integer overflow in `git archive`, `git log --format` leading to RCE in git CVSS 3.1CRITICAL 9.8
- TI-2021-04400 malicious repositories can execute remote code while cloning CVSS 3.1HIGH 8.0
- TI-2024-21101 Git's recursive clones on case-insensitive filesystems that support symlinks are susceptible to Remote Code Execution CVSS 3.1CRITICAL 9.1
- TI-2023-10933 "git apply --reject" partially-controlled arbitrary file write CVSS 3.1HIGH 7.5
Sources
- CVE-2024-32004 · CVE Program
- CVE-2024-32004 · NVD
- FIRST EPSS
- CVE-2024-32004 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences