Priority HIGH 72
GNU Mailman 2.1.39, as bundled in cPanel (and WHM), allows unauthenticated attackers to read arbitrary files via ../ directory traversal at /mailman/private/mailman (aka the private archive authentication endpoint) via t…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.01405 · Published 2025-04-20 · No fix listed CWE-24
Priority HIGH 68
GNU Mailman 2.1.39, as bundled in cPanel (and WHM), in certain external archiver configurations, allows unauthenticated attackers to execute arbitrary OS commands via shell metacharacters in an email Subject line.
CVSS 3.1HIGH 8.1· Network · No auth · No interaction · EPSS 0.00602 · Published 2025-04-20 · No fix listed CWE-78
Priority MEDIUM 63
GNU Mailman 2.1.39, as bundled in cPanel (and WHM), allows unauthenticated attackers to create lists via the /mailman/create endpoint.
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.00482 · Published 2025-04-20 · No fix listed CWE-863
Priority MEDIUM 44
Directory traversal vulnerability in GNU Mailman before 2.1.20, when not using a static alias, allows remote attackers to execute arbitrary files via a ..
CVSS 2.0HIGH 7.6· Network · No auth · Interaction — · EPSS 0.07908 · Published 2015-04-13 · Partial fix CWE-22
Priority MEDIUM 42
Cross-site scripting vulnerability in Mailman before 2.0.12 allows remote attackers to execute script as other users via a subscriber's list subscription options in the (1) adminpw or (2) info parameters to the ml-name f…
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.06105 · Published 2002-08-14 · Fixed
Priority MEDIUM 42
Cross-site scripting vulnerabilities in Mailman before 2.0.11 allow remote attackers to execute script via (1) the admin login page, or (2) the Pipermail index summaries.
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.06302 · Published 2002-05-31 · Fixed
Priority MEDIUM 41
Cross-site request forgery (CSRF) vulnerability in the admin web interface in GNU Mailman before 2.1.15 allows remote attackers to hijack the authentication of administrators.
CVSS 3.0HIGH 8.8· Network · No auth · User interaction · EPSS 0.0153 · Published 2016-09-02 · Will not fix CWE-352
Priority MEDIUM 41
Cross-site request forgery (CSRF) vulnerability in the user options page in GNU Mailman 2.1.x before 2.1.23 allows remote attackers to hijack the authentication of arbitrary users for requests that modify an option, as d…
CVSS 3.0HIGH 8.8· Network · No auth · User interaction · EPSS 0.01613 · Published 2016-09-02 · Partial fix CWE-352
Priority MEDIUM 40
Multiple cross-site scripting (XSS) vulnerabilities in Mailman before 2.1.9rc1 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.
CVSS 2.0MEDIUM 6.8· Network · No auth · Interaction — · EPSS 0.06948 · Published 2006-09-06 · Fixed
Priority MEDIUM 40
Mailman 2.1.4 through 2.1.6 allows remote attackers to cause a denial of service via a message that causes the server to "fail with an Overflow on bad date data in a processed message," a different vulnerability than CVE…
CVSS 2.0HIGH 7.8· Network · No auth · Interaction — · EPSS 0.03072 · Published 2005-12-11 · Fixed
Priority LOW 39
In GNU Mailman before 2.1.38, a list member or moderator can get a CSRF token and craft an admin request (using that token) to set a new admin password or make other changes.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00757 · Published 2021-12-02 · Partial fix · 2.1.38 CWE-352
Priority LOW 38
GNU Mailman before 2.1.35 may allow remote Privilege Escalation.
CVSS 3.1HIGH 8.0· Network · Low privileges · User interaction · EPSS 0.01332 · Published 2021-10-21 · Partial fix CWE-352
Priority LOW 38
Format string vulnerability in Mailman before 2.1.9 allows attackers to execute arbitrary code via unspecified vectors.
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.02652 · Published 2006-09-19 · No fix listed
Priority LOW 38
Mailman 2.0.x before 2.0.6 allows remote attackers to gain access to list administrative pages when there is an empty site or list password, which is not properly handled during the call to the crypt function during auth…
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.02522 · Published 2002-06-25 · No fix listed
Priority LOW 36
The password generation in mailman before 2.1.5 generates only 5 million unique passwords, which makes it easier for remote attackers to guess passwords via a brute force attack.
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.01616 · Published 2005-01-19 · No fix listed
Priority LOW 35
Cross-site scripting (XSS) vulnerability in the web UI in Mailman before 2.1.26 allows remote attackers to inject arbitrary web script or HTML via a user-options URL.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.04569 · Published 2018-01-23 · Partial fix CWE-79
Priority LOW 34
/options/mailman in GNU Mailman before 2.1.31 allows Arbitrary Content Injection.
CVSS 3.1MEDIUM 6.5· Network · No auth · User interaction · EPSS 0.02698 · Published 2020-05-06 · Partial fix CWE-74
Priority LOW 34
An issue was discovered in GNU Mailman before 2.1.28.
CVSS 3.0MEDIUM 6.5· Network · No auth · User interaction · EPSS 0.0253 · Published 2018-07-12 · Partial fix · 2.1.28 CWE-20
Priority LOW 34
Cross-site scripting (XSS) vulnerability in the admin CGI script for Mailman before 2.1.4 allows remote attackers to steal session cookies and conduct unauthorized activities.
CVSS 2.0MEDIUM 6.8· Network · No auth · Interaction — · EPSS 0.01997 · Published 2004-01-15 · Fixed
Priority LOW 33
Mailman 1.1 allows list administrators to execute arbitrary commands via shell metacharacters in the %(listname) macro expansion.
CVSS 2.0HIGH 7.2· Local · No auth · Interaction — · EPSS 0.00675 · Published 2001-01-22 · No fix listed
Priority LOW 32
GNU Mailman 2.x before 2.1.30 uses the .obj extension for scrubbed application/octet-stream MIME parts.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.02288 · Published 2020-04-24 · Partial fix CWE-79
Priority LOW 31
In GNU Mailman before 2.1.36, the CSRF token for the Cgi/admindb.py admindb page contains an encrypted version of the list admin password.
CVSS 3.1MEDIUM 6.5· Network · Low privileges · No interaction · EPSS 0.01153 · Published 2021-11-12 · Will not fix CWE-522
Priority LOW 30
In GNU Mailman before 2.1.36, a crafted URL to the Cgi/options.py user options page can execute arbitrary JavaScript for XSS.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.01381 · Published 2021-11-12 · Will not fix CWE-79
Priority LOW 30
An issue was discovered in Mailman Core before 3.3.5.
CVSS 3.1MEDIUM 6.3· Local · Low privileges · No interaction · EPSS 0.00299 · Published 2023-04-15 · Fixed in 3.3.5 CWE-208
Priority LOW 28
Cross-site scripting vulnerability in Mailman 2.1.26 and earlier allows remote authenticated attackers to inject arbitrary web script or HTML via unspecified vectors.
CVSS 3.0MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.02048 · Published 2018-07-26 · Partial fix CWE-79
Load more